Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Forum Module /

Discuss the Forum Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Reply doesn't display form


Reply


4 Posts   1139 Views

Avatar
websage

Community Member, 6 Posts

15 August 2009 at 6:12am

Hi All,

I would need help with the following as I don't get any further.
I am using SS 2.3.2 and forum 0.2.0 on PHP 5.2.3

My problem: When I click to reply on a topic the reply form doesn't appear. Just the empty template.
My reply link looks like this: http://www.domain.tld/general-discussion/reply/3

What I already tried:

I set up Director::set_environment_type("dev"); in /mysite/_config.php but don't get no error output.
Then I checked the HTML output: <div id="Content"> </div> holds no content at all.

Where I can look further?

Any help is appreciated. Thank you.

Regards

Frank

Avatar
websage

Community Member, 6 Posts

15 August 2009 at 2:10pm

I checked getReplyForm() and replyform() in the forum.php to see if permissions are checked correctly.
All fine. After that I realized there must be something wrong with the template which is a modified one
based on blackcandy.

Adding a simple

<div class="clear"><!-- --></div>

before the Forumheader line in ForumReply.ss

<% include ForumHeader %>

helped to create a correct output of $Content in Page.ss

Hope it will help anyone someday :-)

Avatar
MarkAB

Community Member, 30 Posts

11 August 2010 at 1:17am

I know this is an old post but I'm having the same problem myself & have tried making the above edit to my code, but still having no joy. I could REALLY do with some help with this as it's one of the final parts of my site I have left to do - typically it's one of the most important areas too!!

Thanks in advance for any advice!!

Avatar
MarkAB

Community Member, 30 Posts

12 August 2010 at 2:20am

Could someone PLEASE tell me how I can get some advice on this please, even if I have to pay for it??