Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

First time installation on 1&1 server - friendly url problem


Reply

4 Posts   2229 Views

Avatar
Lucyjamm

28 November 2009 at 2:00am Community Member, 6 Posts

I have built my site in my local server xampp, and was following the instructions on how to upload to a web server http://doc.silverstripe.org/doku.php?id=publishing-to-web-server but when Silverstripe tried to install, I got the following error:

Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
mod_rewrite is enabled
AllowOverride All is set for your directory

I have been over and over lots of posts relating to this error but nothing seems to work and I'm pulling my ever thinning hair out!

I am trying to install on to a 1and1 uk server.

Please could someone help explain the error really really patronisingly as I just don't understand what to do!!

Thank you in advance!

Lucy

Avatar
baba-papa

28 November 2009 at 9:09am Community Member, 279 Posts

SilverStripe needs the modrewrite. Maybe your webspace doesn´t have that. Check with your provider.

Avatar
Lucyjamm

1 December 2009 at 4:44am Community Member, 6 Posts

Hi baba papa,

I have contacted 1&1 as you suggested and they have refered me to this link: http://faq.oneandone.co.uk/website_building/website_publishing/htaccess/4.html. But I don't understand it all really and I could do with some further assistance from anyone who thinks they can help.

I have taken a look at some past dicussions on this forum and have tried adding:

RewriteEngine On
RewriteBase /

to my .htaccess file and this has not worked either.

The link above told me to add this:

RewriteEngine on
RewriteBase /
RewriteRule ^([a-z]+)\.html$ /index.php?$1 [R,L]

and this did not work.

I am now completely stuck, I have tried installing, deleting, installing again, I have tried a few times to start a fresh install and I get the same error each time. If the tech help at 1&1 are saying its something I need to do, is there anything else I can try?

Any help would be really really appreciated.

Thank you.

Lucy

Avatar
baba-papa

1 December 2009 at 9:06pm Community Member, 279 Posts

Hallo Lucy,

I´m not very good when it comes to server questions. There are many threads concerning webspace providers. Take a look at the installation forum.