Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

error saving content need a little help [edited]

Go to End

13 Posts   2085 Views


17 December 2009 at 11:35pm (Last edited: 18 December 2009 12:37am), Community Member, 211 Posts


On some pages of the site I'm getting the message when I try to publish :"error saving"

I found out something weird :

I had 3 pages with this error

I have erased and recreated 2 of them and evrything is fine I can save and published them.
Then I tried to save the third one again without changing it (erase/create) it was still not working wich seems normal but the two first that have been recreated are not working anymore

------------------- end of edit

so far I did :

-Set devmod on with Director::set_environment_type("dev");
-Used firebug wich has found 2 errors that looked the same it says :

and then this is what I get

I think it has to do with erasing some database entry but I'm not sklilled enough to understand it properly
can anyone help

Thanks a lot

$("sitetree").setNodeTitle("185", "<span title=\"Modifi\xE9 sur le site brouillon\" class=\"modified\">num\xE9ro en cours</span>");
$("Form_EditForm").loadActionsFromString("<input class=\"action delete\" id=\"Form_EditForm_action_unpublish\" type=\"submit\" name=\"action_unpublish\" value=\"Retirer du site publi\xE9\" title=\"Retirer du site publi\xE9\" /> <input class=\"action delete\" id=\"Form_EditForm_action_rollback\" type=\"submit\" name=\"action_rollback\" value=\"Annuler les changements brouillons\" title=\"Annuler les changements brouillons\" /> <input class=\"action delete\" id=\"Form_EditForm_action_delete\" type=\"submit\" name=\"action_delete\" value=\"Supprimer du site brouillon\" title=\"Supprimer du site brouillon\" /> <input class=\"action\" id=\"Form_EditForm_action_save\" type=\"submit\" name=\"action_save\" value=\"Sauvegarder\" title=\"Sauvegarder\" /> <input class=\"action\" id=\"Form_EditForm_action_publish\" type=\"submit\" name=\"action_publish\" value=\"Enregistrer &amp;amp; Publier\" title=\"Enregistrer &amp;amp; Publier\" /> ");
$("Form_EditForm").updateStatus("Saved (update)");
statusMessage("Enregistr\xE9", "good");
if (typeof tinyMCE != "undefined") {
tinyMCE.init({mode: "none", editor_selector: "htmleditor", width: "100%", auto_resize: false, theme: "advanced", theme_advanced_layout_manager: "SimpleL


20 December 2009 at 5:04pm Community Member, 97 Posts

What version of SS are you using?

And do check that you're actually logged into the CMS. I've occasionally had this problem only because I'd logged myself out of the site in another tab. Finally, it might be because of the specific stuff you have in your page. Is there anything complicated in there, like trying to include Javascript or something?


20 December 2009 at 11:41pm Community Member, 211 Posts


Thanks for your concern

my version is 2.3.3

I checked I was not logged out on another tab

There is no javascript what I dont get is that I'm able to save the page for publish, and after a while without change on that page but on another one it gives me an error on the page that was working.

Recreating page doesn't work I also cheked that the ''wrong" page was properly erased from the database (page and site tree)

It is driving me crazy because I can't find any logic in this.




21 December 2009 at 7:09am Community Member, 97 Posts

I suggest you at least upgrade to 2.3.4, which fixes bugs and more importantly, closes some security holes. Then try again.



21 December 2009 at 8:41am Community Member, 211 Posts


I tought of that but as the site is now online I'm affraid of making this upgrade and having some new troubles, because Im using forms and newsltterr wich is a sensitive module.

what do you think .

Was upgrade smooth in you case .



21 December 2009 at 10:02am Community Member, 97 Posts

I've not actually done an upgrade from 2.3.3 to 2.3.4, but see this post:



21 December 2009 at 11:49pm Community Member, 3 Posts

I'm having the same error for over a week now, in 2.3.4, "Error saving content" whenever we try to save in the CMS. PHP seems to be fine, ditto MySQL, the server is a fresh install of Ubuntu 9.10 Server Edition.

We can edit and even delete pages in the CMS, so there is db communication there and the server admin is adamant that all permissions are correct. Yet still we're getting this error. Tried flushing, checking the content for extraneous or rogue JS, scoured the SS forum and googlenet for answers and solutions, none of which seem to have the desired effect. This all started happening out of the blue. What is of note is that in the CMS, there's only one page view option, namely Draft Site; no Published Site. And the published site is accessible and viewable, replete with any new pages we add in the CMS.

Mind is very boggled.


21 December 2009 at 11:56pm Community Member, 211 Posts


At least I'm not alone

The weird thing for me is that it occurs on some pages and not others.

And I cheked pretty much everything like you did.

I'm very puzzled + clients getting mad

hope we will find a way


Go to Top