Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[Solved] mod_rewrite


Reply

752 Views

Avatar
jseth

11 January 2010 at 2:26am (Last edited: 11 January 2010 3:13am), Community Member, 98 Posts

I found that FollowSimLinks is not how my server likes it spelled - I needed to change it to FollowSymLinks SymLinksifOwnerMatch, and I got the happy Successful Installation screen.

I am having a problem with mod_rewrite. phpinfo() shows mod_rewrite enabled, however silverstripe rewrite test says it is not. I created a simple test with two simple html files and a .htaccess file to rewrite one html file to the other, but that also does not display the second html file when the first's url is entered in the browser. I have the directories set in the httpd.conf file, but when I tried to add the FollowSimLinks option, when I restart apache, it responds "illegal option". I'm not an apache expert by any means, and don't know how to fix this. Can anyone clarify this for me? Thank you.