Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Terribly slow CMS


Reply

40 Posts   8069 Views

Avatar
Judge

22 January 2010 at 4:14am (Last edited: 22 January 2010 4:20am), Community Member, 79 Posts

If I try turning the site on to development mode (example.co.uk/anypage?isDev=1) I just get this error, along with a white screen:

No current controller available in /var/www/vhosts/example.co.uk/httpdocs/sapphire/core/control/Controller.php on line 343

   public static function curr() {
      if(Controller::$controller_stack) {
         return Controller::$controller_stack[0];
      } else {
         user_error("No current controller available", E_USER_WARNING);
      }
   }

It did ask for a username and password the first time. I assume by "username" it means "administrator email"?

Sorry if this is beginning to drift off-topic.

-- Jason

Avatar
Fuzz10

22 January 2010 at 4:19am Community Member, 787 Posts

Hmmm... no clue there .. Are you sure you typed the URL correctly ?

e.g. www.blabla.com?isDev=1

Indeed, you should fill in your admin credentials when silverstripe asks....

Avatar
Judge

22 January 2010 at 4:21am (Last edited: 22 January 2010 4:29am), Community Member, 79 Posts

When the debugging tools need debugging before we can debug, we are pretty much stuffed in terms of moving forward :-(

Edit: isTest=1 works, so that helps by being able to view queries and various debug information.

Avatar
Fuzz10

22 January 2010 at 4:31am Community Member, 787 Posts

;-)

Well .. isDev works fine here ... Never had any problems with it..

Avatar
Judge

22 January 2010 at 4:38am Community Member, 79 Posts

The error is followed by this one:

Call to a member function getSession() on a non-object in /var/www/vhosts/example.co.uk/httpdocs/sapphire/core/Session.php on line 60

Could be something to do with sessions. I assume once you put the site into development or test mode, it is just for you session and not for all sessions across the whole site? I can imagine how easy it would be to switch it on to check something in a live site and forget to turn it off, so you would not want other people being able to get in there and view the internals with a few choice parameters.

I have seen that type of thing happen on other sites when developers accidentally leave PHPbug code turned on, and up pops debug messages in my FF browser. Whoops.

-- Jason

Avatar
Fuzz10

22 January 2010 at 4:40am Community Member, 787 Posts

Just for your session indeed... It would be quite silly otherwise...

Weird error you got there....

Avatar
Billy Bob

22 January 2010 at 8:35am Community Member, 9 Posts

Last post on this subject. I have 'wasted' too much time and effort and have businesses to run, and 27 years in this industry believe me I know a problem is software, hardware or configuration issues when I see one, and this one is definitely a SS issue.

I have tried numerous times with V 2.3.4 it's hopeless and get's worse. I have tried a friends brand new dedicated server, no sites loaded at all on it, tried V 2.3.4, tried all the workarounds for speed/performance improvements. Absolutely no different whatsoever. Tried V 2.4 on the original server, slight improvement but nothing to sing a song about. Tried V 2.4 on my friends brand new Dell dedicated server and it's marginally better but not usable in a live environmet. The time I have wasted pi**ing about with SS I could have had the site done and dusted.

I much appreciate all your input and assistance but the use of SS has been binned. I 'may' call back in 6 months or so and see how things are then and give it a try.

Avatar
MateuszU

22 January 2010 at 8:54am Community Member, 89 Posts

Judge, I think the dev mode gets enabled anyway, it just crashes immediately afterwards. This happens on clean 2.4 install, here is a ticket: http://open.silverstripe.org/ticket/4947 . Which version are you using, Judge?