Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

googlesitemap question (xml file not showing)


Reply


8 Posts   869 Views

Avatar
servalman

Community Member, 211 Posts

21 January 2010 at 4:12am

Hello

I jus enabled the googlesitemap module and as it said in docs I got now a "goolglesitemap " tab for every page in the admin.

So I saved and published all the pages again but the I can't see any sitemap.xml file at the root of the website .

Did I missed something ?

Thanks for help

Thomas

Avatar
Taffy

Community Member, 119 Posts

21 January 2010 at 4:48am

Edited: 21/01/2010 4:48am

Do you see the xml when you hit http://mysite.com/sitemap.xml ?

Avatar
servalman

Community Member, 211 Posts

21 January 2010 at 4:52am

Hello

When I type what you suggested this is what I get :

Fatal error: Class 'SS_Datetime' not found in /var/www/vhosts/michele-manceaux.com/httpdocs/googlesitemaps/code/GoogleSitemap.php on line 65

Any idea ?

Thanks for your time

Avatar
Taffy

Community Member, 119 Posts

21 January 2010 at 5:26am

What version of SS are you using? Recently upgraded?

Avatar
servalman

Community Member, 211 Posts

21 January 2010 at 5:29am

I'm using 2.3.4
and I used the last trunk (the one I got today trunk-r97267

Thanks again

I'm hoping to solve this ;)

T

Avatar
Willr

Forum Moderator, 5513 Posts

21 January 2010 at 12:21pm

You won't be able to use trunk googlesitemaps with 2.3. A recent change has made trunk 2.4 only compatible. You will have to use an older tag for 2.3 like googlesitemaps/tags/0.1.2.

Avatar
Judge

Community Member, 79 Posts

22 January 2010 at 11:18am

Edited: 22/01/2010 11:29am

Is this a general issue with modules - incompatibilities between different versions and the core? I've not got the "Google Sitemaps" tab under the content tab of pages, and would have had no idea that it was supposed to be there if I had not stumbled upon this thread.

Are there any plans to provide multiple versions of the modules to download, since the latest modules don't all seem to be compatible with the latest core CMS download? WordPress.org keeps a history of all previous released versions (it automatically uses the tags to find the versions in subversion) and it is possible to tag each against the core application version that it works with. There way there are fewer surprises.

I'm now wondering just how much more of the administration screens are being hidden from me. Installing modules does tend to leave the admin screens looking much the same as ever.

-- Jason

Edit: or it could just mean the module is not "installed"? The sitemap.xml works for me, but it's not being added to the SiteTree - the total opposite of the OP's problem, I think.

Avatar
Willr

Forum Moderator, 5513 Posts

22 January 2010 at 11:34am

Edited: 22/01/2010 2:42pm

Are there any plans to provide multiple versions of the modules to download, since the latest modules don't all seem to be compatible with the latest core CMS download

Yes. We have some updates to the modules section to fix this issue currently in testing now.

Edit - It has now been announced http://groups.google.com/group/silverstripe-dev/browse_thread/thread/58f80c53dd9288f9