Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Google Crawl Errors


Reply


2 Posts   739 Views

Avatar
cmcm

Community Member, 2 Posts

22 January 2010 at 11:36pm

Hi,
I have just transferred a silverstripe site from one hosting company to another,
The newly installed site is working perfectly but google is having a problem crawling it and some are actually showing up in search results.

It seems to be adding different page urls to the end of a a proper page url a few examples:

example.com/faceal-colour/stone-coating/brick-waterproofing/pss20-clear/graffiti-removal-services/

where these are all the proper individual pages:

example.com/faceal-colour/
example.com/stone-coating/
example.com/brick-waterproofing/
example.com/pss20-clearr/
example.com/graffiti-removal-services/

This is only a problem with search engines the site navigation is fine, how i noticed this problem is through google webmaster tools
which throws up 4,000 404 errors as it can't find these phantom urls

Any help would be appreciated,

Thanks

Avatar
zenmonkey

Community Member, 528 Posts

24 January 2010 at 9:31am

Try resubmitting your sitemap to make sure its using a newly generated fresh one. I usually then crank up the crawl rate for a few days.