Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

UPGRADE 2.2.2 >> 2.3.5 >> Nothing Work!!


Reply


6 Posts   1562 Views

Avatar
snipou2k

Community Member, 10 Posts

9 February 2010 at 5:10am

Hi,
I am a French user so I hope you understand what I say sorry in advance!
I managed better or worse time to install version 2.3.5 but now I have several problems:

First:
My contact forms are not available without the module.
So I downloaded and installed: UserForm-v0.2.1
db/build/?flush=1 everything seems good.
Then I try to add a field in the form and I get the message: "add new filed" and "Error creating field" I can no longer use my forms!

Second:
I installed the module forum-v0.2.5.
Hence the migration because with my 2.3.5 version 2.2.2 it does not work!
The finding as it appears: db/build/?Flush=1 everything seems good.
but I can not post messages in my own forum!

Where and how can I moderate the forum? I did not find how moderate the forum ...

Thank you kindly help me because it is essential that the contact form & the forum is operational and that the forum can be moderated by a third person

Sorry again for my poor English I hope you will understand me.
Best regards,

For French users:
J'ai réussis temps bien que mal à installer la version 2.3.5 mais maintenant j'ai plusieurs problème :

En premier :
Mes formulaires de contacts ne sont plus disponible sans module.
J'ai donc téléchargé et installé : userforms-v0.2.1
db/build/?flush=1 tout parait bon.
Ensuite, j'essaye d'ajouter un champ dans le formulaire et j'ai le message : "add new filed" puis "Error creating field" je ne peux donc plus utiliser mes formulaires !

En second:
J'ai installé le module : forum-v0.2.5.
D'où la migration en 2.3.5 car avec ma version 2.2.2 ça ne fonctionnait pas!
La aussi ça parait concluant:db/build/?flush=1 tout parait bon.
mais je ne peux pas poster des messages dans mon propre forum !!

Où et comment je peux modérer le forum? Je n'ai pas trouvé comment modérer le forum...

Merci de bien vouloir m'aider car il faut absolument que le formulaire de contact & le forum soit opérationnel et que le forum puisse être modéré par une tierce personne.

Cordialement

Avatar
snipou2k

Community Member, 10 Posts

10 February 2010 at 4:24am

Nobody can help me then?

Avatar
BigChris

Community Member, 63 Posts

10 February 2010 at 6:29am

I am not sure if this will be of help, but as of version 2.3. the /db/build/ is now /dev/build/. I think db/build/ still works.

But try /dev/build/?flush=all

and also in /mysite/_config.php
add the following line to output the errors.

Director::set_environment_type("dev");

Also, if you can. Remove the modules. Run the dev/build and then add in each module in turn.

Hope that helps.

Avatar
snipou2k

Community Member, 10 Posts

10 February 2010 at 7:57am

Thank you for your help

I have deleted all the modules and added the line:
Director: set_environment_type ( "dev");
in my / mysite / _config.php

then I / dev / build /? flush = all

and finally I added a module but nothing seems to work.
Instead, my forum to display more error and my contact form does not work

I still need help x)

http://www.areaweb.fr/forums/

[Warning] file_get_contents() [function.file-get-contents]: Filename cannot be empty
GET /forums/

Line 280 in /homez.139/areaweb/www/sapphire/core/SSViewer.php
Source

271    /**
272     * Used by <% include Identifier %> statements to get the full
273     * unparsed content of a template file.
274     *
275     * @uses getTemplateFile()
276     * @param string $identifier A template name without '.ss' extension or path.
277     * @return string content of template
278     */
279    public static function getTemplateContent($identifier) {
280       return file_get_contents(SSViewer::getTemplateFile($identifier));
281    }
282    
283    /**
284     * @ignore
285     */
286    static private $flushed = false;

Trace

* file_get_contents()
Line 280 of SSViewer.php
* SSViewer::getTemplateContent(Menu2)
Line 2 of SSViewer.php(403) : runtime-created function
* __lambda_func(Array)
* preg_replace_callback(/<% include +([A-Za-z0-9_]+) +%>/,�lambda_50,<!-- template /homez.139/areaweb/www/themes/areaweb/areaweb_forum/templates/Layout/ForumHolder.ss --> <!-- include /homez.139/areaweb/www/themes/areaweb/areaweb_forum/templates/Includes/ForumHeader.ss --> <div id="ForumContent"> <% include ForumLogin %> <h1 class="genericTitle">$Parent.Title</h1> <% include Menu2 %> <div class="forumFeatures"> <div class="featureRight"> <p class="forumStats">$TotalPosts <strong>Posts</strong> in $TotalTopics <strong>Topics</strong> by $TotalAuthors <strong>members</strong></p> <span class="jumpTo">Jump to:</span> <select onchange="if(this.value) location.href = this.value"> <option value="">-- Select --</option> <% control Forums %> <% if CheckForumPermissions %> <option value="$Link">$Title</option> <% end_if %> <% end_control %> </select> <div id="ForumSearch"> <form action="<% if ForumHolderURLSegment %>{$ForumHolderURLSegment}<% else %>{$URLSegment}<% end_if %>/search/" method="get"> <fieldset> <!-- span>Search:</span --> <input class="text" type="text" name="for" /> <input class="submit" type="submit" value="Search"/> </fieldset> </form> </div> </div> <div class="featureLeft"> <h2>$Subtitle</h2> <% if Abstract %>$Abstract<% else %>$Content<% end_if %> <span class="breadcrumbs"><strong>$Breadcrumbs</strong></span> </div> <div class="clear"><!-- --></div> </div> <!-- end include /homez.139/areaweb/www/themes/areaweb/areaweb_forum/templates/Includes/ForumHeader.ss --> <div class="forumHolderFeatures"> <table id="TopicList"> <tr> <th class="odd">Forum</th> <th class="even">Threads</th> <th class="odd">Posts</th> <th class="even">Last Post</th> </tr> <% control AllChildren %> <% if CheckForumPermissions %> <tr class="$EvenOdd"> <td class="forumCategory odd"> <a class="topicTitle" href="$Link" title="Go to the $Title.EscapeXML topic">$Title</a> <% if Content %><span class="summary">$Content.Summary</span><% end_if %> </td> <td class="count even"> $NumTopics </td> <td class="count odd"> $NumPosts </td> <td class="even lastPost"> <% control LatestPost %> <a class="topicTitle" href="$Link#post{$ID}" title="Go to latest post in {$Topic.Title.EscapeXML}"><% control Topic %>$Title.LimitCharacters(20)<% end_control %></a> <% control Author %> <p class="userInfo">by <% if Link %><a href="$Link" title="Click here to view <% if Nickname %>$Nickname.EscapeXML<% else %>Anon<% end_if %>&#39;s profile"><% if Nickname %>$Nickname<% else %>Anon<% end_if %></a><% else %><span>Anon</span><% end_if %></p> <% end_control %> <p class="userInfo">$Created.Ago</p> <% end_control %> </td> </tr> <% end_if %> <% end_control %> </table> </div> <!-- include /homez.139/areaweb/www/themes/areaweb/areaweb_forum/templates/Includes/ForumFooter.ss --> <div id="CurrentlyOnline"> <h3>Currently Online:</h3> <p> <% if CurrentlyOnline %> <% control CurrentlyOnline %> <% if Link %><a href="$Link" title="<% if Nickname %>$Nickname<% else %>Anon<% end_if %> is online"><% if Nickname %>$Nickname<% else %>Anon<% end_if %></a><% else %><span>Anon</span><% end_if %><% if Last %><% else %>,<% end_if %> <% end_control %> <% else %> <span>There is nobody online.</span> <% end_if %> </p> <p> <span>Welcome to our latest member:</span> <% control LatestMember %> <% if Link %><a href="$Link" title="<% if Nickname %>$Nickname<% else %>Anon<% end_if %> is online"><% if Nickname %>$Nickname<% else %>Anon<% end_if %></a><% else %><span>Anon</span><% end_if %><% if Last %><% else %>,<% end_if %> <% end_control %> </p> </div> </div> <!-- end include /homez.139/areaweb/www/themes/areaweb/areaweb_forum/templates/Includes/ForumFooter.ss --> <!-- end template /homez.139/areaweb/www/themes/areaweb/areaweb_forum/templates/Layout/ForumHolder.ss -->)
Line 403 of SSViewer.php
* SSViewer::parseTemplateContent(<% include ForumHeader %> <div class="forumHolderFeatures"> <table id="TopicList"> <tr> <th class="odd">Forum</th> <th class="even">Threads</th> <th class="odd">Posts</th> <th class="even">Last Post</th> </tr> <% control AllChildren %> <% if CheckForumPermissions %> <tr class="$EvenOdd"> <td class="forumCategory odd"> <a class="topicTitle" href="$Link" title="Go to the $Title.EscapeXML topic">$Title</a> <% if Content %><span class="summary">$Content.Summary</span><% end_if %> </td> <td class="count even"> $NumTopics </td> <td class="count odd"> $NumPosts </td> <td class="even lastPost"> <% control LatestPost %> <a class="topicTitle" href="$Link#post{$ID}" title="Go to latest post in {$Topic.Title.EscapeXML}"><% control Topic %>$Title.LimitCharacters(20)<% end_control %></a> <% control Author %> <p class="userInfo">by <% if Link %><a href="$Link" title="Click here to view <% if Nickname %>$Nickname.EscapeXML<% else %>Anon<% end_if %>&#39;s profile"><% if Nickname %>$Nickname<% else %>Anon<% end_if %></a><% else %><span>Anon</span><% end_if %></p> <% end_control %> <p class="userInfo">$Created.Ago</p> <% end_control %> </td> </tr> <% end_if %> <% end_control %> </table> </div> <% include ForumFooter %>,/homez.139/areaweb/www/themes/areaweb/areaweb_forum/templates/Layout/ForumHolder.ss)
Line 324 of SSViewer.php
* SSViewer->process(ForumHolder_Controller)
Line 349 of SSViewer.php
* SSViewer->process(ForumHolder_Controller)
Line 172 of Controller.php
* Controller->handleAction(HTTPRequest)
Line 129 of RequestHandler.php
* RequestHandler->handleRequest(HTTPRequest)
Line 119 of Controller.php
* Controller->handleRequest(HTTPRequest)
Line 29 of ModelAsController.php
* ModelAsController->handleRequest(HTTPRequest)
Line 277 of Director.php
* Director::handleRequest(HTTPRequest,Session)
Line 121 of Director.php
* Director::direct(/forums/)
Line 118 of main.php

Avatar
Willr

Forum Moderator, 5513 Posts

10 February 2010 at 11:09am

[Warning] file_get_contents() [function.file-get-contents]: Filename cannot be empty
GET /forums/

I think this is because forum has an include template for a template that isn't working. One possible solution you can do is edit that SSViewer.php. Or have a play in the forum module to see what include its failing on - Probably something in ForumHolder.ss

return file_get_contents(SSViewer::getTemplateFile($identifier));

to

return (SSViewer::getTemplateFile($identifier)) ? file_get_contents(SSViewer::getTemplateFile($identifier)) : false;

Avatar
snipou2k

Community Member, 10 Posts

10 February 2010 at 11:23am

Edited: 10/02/2010 11:30am

thank you the error has disappeared

but now I still can not post in the forum, moderated the forum and my contact form does not work.

Thank you

You're logged in as Admin

Start new topic

I'm sorry, but you can't post to this forum until you've logged in. If you want to log in as someone else, do so below. If you're logged in and you still can't post, you don't have the correct permissions to post.
         
Email
   
Password