Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Error getting files


Reply


6 Posts   1575 Views

Avatar
svenmagnus

Community Member, 2 Posts

10 February 2010 at 12:38am

Edited: 10/02/2010 6:40am

I am very new to Silverstripe and have just installed everything using the newest version of WAMP.
Now I try to insert uploaded images using the TinyMCE but the images don't show up in the panel on the right and I receive an error message with the content "Error getting files"

Has anybody got an idea what went wrong?

Avatar
Willr

Forum Moderator, 5513 Posts

10 February 2010 at 11:13am

If you have firebug installed (firefox plugin) then you can look under the 'console' option in firebug and see the request which gets sent to load the images. If you click that request you can drill down into the 'Response' - this response will hopefully contain the full error message.

Avatar
svenmagnus

Community Member, 2 Posts

10 February 2010 at 11:20pm

Edited: 10/02/2010 11:40pm

Now I installed Firebug and received this error message:

500//
getTransport() protot...6464321 (Zeile 658)
these() protot...6464321 (Zeile 196)
[Break on this error] function() {return new ActiveXObject('Microsoft.XMLHTTP')},\n
protot...6464321 (Zeile 658)

But I have no clue what it means

I found out something else.

When I start phpMyAdmin...

there is a yellow i (information mark) which says:
Die zusätzlichen Funktionen für verknüpfte Tabellen wurden automatisch deaktiviert. Klicken Sie hier um herauszufinden warum.
Translated: The additional functions for connected tables were deactivated automatically. Click here to find out why.

Server: localhost
$cfg['Servers'][$i]['pmadb'] ... fehlerhaft [ Dokumentation ]
$cfg['Servers'][$i]['relation'] ... fehlerhaft [ Dokumentation ]
Allgemeine Verknüpfungsfunktionen: Deaktiviert

$cfg['Servers'][$i]['table_info'] ... fehlerhaft [ Dokumentation ]
Anzeige verknüpfter Daten: Deaktiviert

$cfg['Servers'][$i]['table_coords'] ... fehlerhaft [ Dokumentation ]
$cfg['Servers'][$i]['pdf_pages'] ... fehlerhaft [ Dokumentation ]
Erzeugen von PDFs: Deaktiviert

$cfg['Servers'][$i]['column_info'] ... fehlerhaft [ Dokumentation ]
Darstellung von Spaltenkommentaren: Deaktiviert
Gespeicherte SQL-Abfrage: Deaktiviert
Darstellungsumwandlung: Deaktiviert

$cfg['Servers'][$i]['history'] ... fehlerhaft [ Dokumentation ]
SQL-Verlaufsprotokoll: Deaktiviert

$cfg['Servers'][$i]['designer_coords'] ... fehlerhaft [ Dokumentation ]
Designer: Deaktiviert

This has maybe something to do with my problem?

Avatar
steve_nyhof

Community Member, 224 Posts

27 March 2010 at 4:42am

Edited: 27/03/2010 4:44am

ERROR [Warning]: Parameter 1 to Hierarchy::loadDescendantIDListInto() expected to be a reference, value given IN GET /admin/EditorToolbar/ImageForm? ....

I was able to fix this by just over writing files under jsparty, but now nothing is happening - seems to come back.

Any idea where this error is coming from and how to correct it?

Thank you,
Steve Nyhof

Avatar
steve_nyhof

Community Member, 224 Posts

28 April 2010 at 3:20am

I fixed this by removing the code in the _config.php file in mysite...

//Director::set_environment_type('dev'); //for development mode

That worked... Up until yesterday when something must have changed. Made a site in the morning and all was perfect. Then 5 hours later, no matter how many sites I tried to make, I kept getting the same error as before...

ERROR [Warning]: Parameter 1 to Hierarchy::loadDescendantIDListInto() expected to be a reference, value given IN GET /admin/EditorToolbar/ImageForm?action_callfieldmethod=1&fieldName=Image&ajax=1&methodName=getimages&folderID=1676&searchText=undefined&cacheKillerDate=1272316794674&cacheKillerRand=4771 Line 525 in /home/bestland/public_html/sapphire/core/Object.php Source ====== 516: if(isset(self::$extra_methods[$this->class][$method])) { 517: $config = self::$extra_methods[$this->class][$method]; 518: 519: switch(true) { 520: case isset($config['property']) : 521: $obj = $config['index'] !== null ? 522: $this->{$config['property']}[$config['index']] : 523: $this->{$config['property']}; 524: * 525: if($obj) return call_user_func_array(array($obj, $method), $arguments); 526: 527: if($this->destroyed) { 528: throw new Exception ( 529: "Object->__call(): attempt to call $method on a destroyed $this->class object" 530: ); 531: } else {

call_user_func_array(Array,Array) line 525 of Object.php Object->__call(loadDescendantIDListInto,Array) Image->loadDescendantIDListInto(Array) line 357 of Hierarchy.php Hierarchy->loadDescendantIDListInto(Array) line 342 of Hierarchy.php Hierarchy->getDescendantIDList(Folder) call_user_func_array(Array,Array) line 525 of Object.php Object->__call(getDescendantIDList,Array) Folder->getDescendantIDList(Folder) line 47 of ThumbnailStripField.php ThumbnailStripField->getimages() line 963 of Form.php Form->callfieldmethod(Array,Form,HTTPRequest) line 246 of Form.php Form->httpSubmission(HTTPRequest) line 129 of RequestHandler.php RequestHandler->handleRequest(HTTPRequest) line 143 of RequestHandler.php RequestHandler->handleRequest(HTTPRequest) line 143 of RequestHandler.php RequestHandler->handleRequest(HTTPRequest) line 122 of Controller.php Controller->handleRequest(HTTPRequest) line 277 of Director.php Director::handleRequest(HTTPRequest,Session) line 121 of Director.php Director::direct(/admin/EditorToolbar/ImageForm) line 118 of main.php

Avatar
B-Side

Community Member, 42 Posts

15 December 2010 at 1:26pm

HI there - was there a resolution to your issue?

I'm getting the same "Error Getting Files" message with 2.3.9.

I have tried removing the set_environment_type variable and increasing the memory_limit setting in php.ini to no effect. The site is running on PHP version 5.2.4. Any ideas?

Many thanks, Jayne