Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Error adding new page


Reply


15 Posts   2203 Views

Avatar
madmaurice

Community Member, 20 Posts

17 February 2010 at 8:33pm

i dont think its an css problem. its seems more to be a javascript problem.

i mean its okay that its hidden. unless you click the create button.
and because the visibility value is directly set in the element and not in a css file i think this value is set by javascript
and should also be removed by javascript. And heres the error its doesnt remove this visibility-style or sets it to "visible"

if you remove that style-attribute from the tag manually it works but only once.^^

Workaround: Just click Go after pressing the Create button. A page is created and you can choose the page type in the page editor on the right
In the tab "Behaviour". Its not a pretty workaround but it works until they fixed this bug. :)

Avatar
madmaurice

Community Member, 20 Posts

17 February 2010 at 8:38pm

@eddieconnecti: did you ran /dev/build?flush=1 ^^ sry if this is a noobic question but most of the problems are the users forgetting one lil detail.

i wish this would be also true for my situation

Avatar
eddieconnecti

Community Member, 26 Posts

17 February 2010 at 8:59pm

I flushed a hundred times, nothing happend. By the way: the database models are registered, so all tables exist! That means that the files where found by the manifest builder and it created tables in the database. It´s just that I can not create a page, because the pagetypes don´t occure in the create dropdown box.

Avatar
madmaurice

Community Member, 20 Posts

18 February 2010 at 12:38am

Edited: 18/02/2010 12:41am

Has any one of you a non installed copy of version 2.3.4 or knows where i can download it?

this is the last version i saw without this error.

EDIT: what the f...
i just checked an old site which had never had this error (hidden page type selection box)
but now it does O.o

am i getting crazy O.o

Avatar
madmaurice

Community Member, 20 Posts

19 February 2010 at 7:41am

How can this error not be important enough to get fixed i mean this is a operation that many people do every day (creating a page) and in 2 versions of silverstripe is has not been fixed??

Avatar
eddieconnecti

Community Member, 26 Posts

19 February 2010 at 12:15pm

I give it up now. Since they seem not to be interested in fixing this bug or telling us help is on the way, I decided to switch back to last version of silverstripe. Maybe try again when new version is no more beta.

Avatar
nykayfabe

Community Member, 4 Posts

9 March 2011 at 6:08pm

Edited: 09/03/2011 6:12pm

I experienced this same error caused by SELECT AND INSERT statements trying to execute on table "Page" which doesn't exist. Not sure if this is still an issue in the latest build but for those running 2.4.2, here's how I fixed it:

/sapphire/core/model/Versioned.php, wrap lines 391-422 in conditional:

if(!isset($manipulation[$table]['fields']['Version'])) {
      if( mysql_num_rows( mysql_query("SHOW TABLES LIKE '".$table."'"))) {
...
      }
}

/sapphire/core/model/Database.php, wrap lines 582 and 583 in conditional:

   if( mysql_num_rows( mysql_query("SHOW TABLES LIKE '".$table."'"))) {
      $sql = "INSERT INTO \"$table\" ($columnList) VALUES ($valueList)";
      $this->query($sql);
   }