Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

DB completely wiped


Reply


5 Posts   785 Views

Avatar
ddshore

Community Member, 12 Posts

13 February 2010 at 3:52am

Hi,
I was building a website with silverstripe in my computer, and stopped using it for a week or so.
I made some modifications to the site, and loaded it again, and I got a message saying "please wait, creating database" or something to this effect, but my whole database disappeared completely. I've checked the db and there's no data there anymore. Anyone have any clue as to what happened? I'm not sure if I should keep using SS anymore, anyone have any similar experiences?

Avatar
Willr

Forum Moderator, 5513 Posts

13 February 2010 at 12:48pm

What version of SilverStripe are you using? Make sure you're fully up to date with the security releases since they could have got in through a hole in an unpatched earlier version.

Avatar
ddshore

Community Member, 12 Posts

13 February 2010 at 5:51pm

I doubt that it could have been that.
It's as localhost, and I'm behind a router, with a firewall.

Avatar
Sean

Forum Moderator, 922 Posts

14 February 2010 at 7:02pm

Are you sure the MySQL databases weren't deleted accidentally, or the database name was changed in the code?

Avatar
ddshore

Community Member, 12 Posts

15 February 2010 at 3:04am

Idid install MifOS, which is a microfinance software, that uses MySQL. That might've affected the database, although it would've been the only db in my computer that was deleted. But you're right, I think I'll also look into that. Thanks.