Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[SOLVED] sitemap.xml and google sitemap tab option 2.3.3


Reply

2 Posts   798 Views

Avatar
steve_nyhof

19 February 2010 at 7:23am (Last edited: 19 February 2010 8:47am), Community Member, 224 Posts

Has anyone ever fixed the issue of the "Not indexed" option in the Google Sitmap tab?

I removed a few lines of code and was able to make it stay, but now it is not doing the work of "Not indexing" the page in the sitemap.xml file.

Only pages where I turn off the menu and search in the behavior tab, shuts them off, but I need the pages in the menu for permission based pages.

What is Show in Search anyway? What does it do? I'm guessing it is for search results using the search box option.

Any help please!

Thank you,
Steve

Avatar
steve_nyhof

19 February 2010 at 8:46am (Last edited: 19 February 2010 8:46am), Community Member, 224 Posts

This is what I did and it seems to work...

Changed this on line 167 from:

'' => _t('SiteTree.PRIORITYAUTOSET','Auto-set based on page depth'),

Changed to:

'-1' => _t('SiteTree.PRIORITYAUTOSET','Auto-set based on page depth'),

--

Then on line 227, I changed

return 0;

to:

return -1;

When you make a new page, it will default to the right level, when you save on "Not indexed" it saves and remove the page from the sitemap.xml file. However, the auto level does not work - good for me!