Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Security/Login shows blank page


Reply


8 Posts   1940 Views

Avatar
jseth

Community Member, 98 Posts

3 March 2010 at 4:36am

Edited: 03/03/2010 4:36am

All was going well. Then I accidently changed the page level of my Home page from 0 to 1. I had to go into phpmyadmin to change it back. It appeared again in the Site Tree in the CMS, and in the browser. I thought all was well. I logged out and later went to log in again, and an http 500 error came up in IE. When I opened it in FireFox, it shows the Security/Login in the URL, and the page is blank. Any ideas on how to fix this, or should I just reinstall?

Avatar
Mo

Community Member, 510 Posts

3 March 2010 at 5:32am

Is your server generating an error log? If so can you post what it output at the time of the error? The "white screen of death" as I like to call it, can be for a multitude of different issues.

Avatar
jseth

Community Member, 98 Posts

3 March 2010 at 7:12am

Hi Mo,
Thanks for replying. If the server's keeping an error log, I'm embarrassed to say I don't know where to look for it. I reinstalled Silverstripe, and thankfully all of my data is fine, I just need to re-do all of the customization of the theme I was using, and reinstall the modules I had previously. I'm figuring I'll stumble over what caused the problem as I try to get the site set up again, but at least the major work, such as the actual pages and all of the data is still in place. Here's hoping it doesn't happen again, and also hoping that I don't make ANOTHER STUPID mistake (imagine that!).

Avatar
Mo

Community Member, 510 Posts

4 March 2010 at 11:50am

What server are you setting this up on? Is it a local server, or one from your host?

You are getting a white screen because your server is configured to hide critical errors (the type that cause PHP to stop processing scripts). If this is a local or development server you could try using altering error_reporting (http://php.net/manual/en/function.error-reporting.php) and display_errors (http://www.php.net/manual/en/errorfunc.configuration.php#ini.display-errors) in php.ini.

If this is a live server, it might be worth contacting your host and finding out where they are logging errors to (don't do the above on a live server :) ).

Mo

Avatar
jseth

Community Member, 98 Posts

5 March 2010 at 2:15am

The site is on our own server here (we're a school), so I will try your suggestions. I appreciate your response - I'm still learning about the server end (Linux server) along with learning Silverstripe, and all the coding stuff... the learning curve is straight up! Thanks again.

Avatar
Mo

Community Member, 510 Posts

6 March 2010 at 3:16am

No probs jseth. If you are running this on a linux server, Error logs be default should be located at /var/logs/apacheX (where x is your version of apache).

Hope you get on with administering linux servers. I dropped Windows server a few years back, in favour of Ubuntu, it can be a bit of difference, but I have found once you get the hang of it all its not to complex. :)

Mo

Avatar
ChrisBryer

Community Member, 95 Posts

6 March 2010 at 4:10am

do you have $Form in your page template? the login page needs that to be present.

Avatar
jseth

Community Member, 98 Posts

6 March 2010 at 4:16am

Hi Chris and Mo,
Chris - Yes, I have $Form in the Page.ss
Mo - thanks, I'll look there.

It appears that I did it again, (changed some code and got the White Screen of Death again), and found that I broke the template! When I put a new template name in the _config.php file, it opened up just fine. Since I've broken the same template twice (nouveau), I think I just stick with this one (blackcandy) and customize it to look like the nouveau one that I customized.

Thanks so much for your help! I'm sure I'll be needing more as time goes by!