Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Access Tab - Not saving editor rights


Reply


823 Views

Avatar
PapaBear

Community Member, 26 Posts

10 March 2010 at 3:56pm

Hi All,

I'm trying to apply edit rights to specific pages for specific groups (The client would like sections to edit their own pages but only their own pages). I've created the appropriate groups - one per section - and added the logins for the administrators of each section. I've also set the access rights (For testing I've just added "Access to all CMS Interfaces").

I'm going through the site and trying to set edit rights. I choose "Only these people" and select "Administrators" and my sub-section group and then Save. If I then refresh the window in the CMS (or navigate to a different page then back) the radio button for "Only these people" is still selected byt the pull down is blank again. Also if I log in as a user from the sub-section the pages are all greyed out (including the page I should be able to edit).

I've attached screenshots of the Security settings for the group and the access tab of one of the affected pages. This fault affects all pages in the site.

I'm running SS v2.3.3.
Can anyone help, please?

Cheers
James.

Attached Files