Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

PROBLEM INSERTING FLASH


Reply


3 Posts   841 Views

Avatar
nolyup

Community Member, 5 Posts

12 March 2010 at 3:26am

Hello all,

I've imported my Flash assets ok but the insert flash button does not work.

I have noticed many posts regarding this problem and haven't seemed to have cracked it.

I'm using SS v3.6 and I'm running it locally using MAMP.

Could someone please explain why this feature is not working?

Thanks

Avatar
Blaza

Community Member, 4 Posts

12 March 2010 at 7:15am

Hi nolyup

Can you be more descriptive in what are you trying to do? Are you using special module?

What I'm guessing is that you are inserting flash code to the page content. Most likely using TinyMCE. And that might be first issue. TinyMCE validates the code and sometimes does not let other JS / Embed codes through.
Other one might be missing JS files if you are using more sophisticated JS solution. Make sure you have those in template.
If you actually do have that flash in page, than there might be issue in paths inside of the flash. Relative vs. Absolute is a big difference. You are running from localhost and therefore /path/page absolute path in flash should do. If you have http://localhost:81/~macuser/path/page you'll need to use the whole thing.

That's what I'm guessing...

Avatar
nolyup

Community Member, 5 Posts

14 March 2010 at 1:09am

Thanks Blaza,

My flash knowledge is limited. I however found this link which helped me understand and implement my swf file.

Cheers