Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Upload broken in 2.4?


Go to End
Reply

55 Posts   12477 Views

Avatar
Tim99

28 March 2010 at 10:51pm Community Member, 10 Posts

Hi,

last week, I installed 2.3.7 and was able to upload files as Admin. All other roles were not able to upload ("file is not a valid upload").

I installed DataObjectManager - and directly uninstalled it. Then I upgraded to 2.4-beta2. Now I can not upload at all. Not even as Admin. I have absolutely no idea, how to solve this problem.

Any ideas?

Avatar
Tim99

1 April 2010 at 7:34pm Community Member, 10 Posts

Just upgraded to 2.4 RC1. Still "file is not a valid upload", even for admins. Am I the only one facing that problem?

Avatar
Tim99

3 April 2010 at 9:54am Community Member, 10 Posts

I just did a fresh install of 2.4 RC1 and the upload just does not work. I have no clue what to do. Would somebody please be so kind and tell me, if his/her uploads are working in 2.4 RC1, so that I can be sure that it's something with my server config or file permissions?

Avatar
honeybunny

3 April 2010 at 11:02am Community Member, 79 Posts

Hi Tim99!
I'm having some issues with other things since I upgraded to 2.4.0-rc, but am able to upload. The funny thing is that I lost the ability to upload after a previous upgrade. I tested a few different file types (jpg, doc, pdf) and had no problem. My best suggestion is to use firebug to see if you can find out what is causing the error.

I know it makes the concept of a cms seem ridiculous, but you should be able to upload directly to the assets folder on your server then access the files from the cms. When my upload wasn't working I had to upload directly to the server, refresh the cms then click on the files & images tab before I could see the files in the upload section of the interface. It didn't matter if I actually saw the file or even open the folder it was in, I just had to go to the files & images tab.

Sorry I can't be more helpful,

HB

Avatar
servalman

20 April 2010 at 2:24am Community Member, 211 Posts

Hi !

Did you solve this proble.

I'm stuck with it right now

Thanks for any advice on that

T

Avatar
Tim99

20 April 2010 at 6:39am Community Member, 10 Posts

Unfortunately, I did not manage to fix the error. What version are you using? Perhaps the SVN-version will work? I don't think that this is a general bug in Silverstripe. Otherwise lots of people would have the same problem.

Avatar
servalman

20 April 2010 at 7:31pm Community Member, 211 Posts

Hi

I'm using 2.4 rc1 to test it on a very small scale website.

The weird thing is that I have the same server//php settings as usual ...

I wil try to install 2.3.6 and let you know if it works

T

Avatar
Tim99

1 May 2010 at 12:30am Community Member, 10 Posts

Originally I had SS 2.3.7 and the upload worked (at least for admins). 2.4-beta2, 2.4-rc1, and 2.4-rc2 all failed. Not even the admin was able to upload. Now I installed 2.3.7 again and the upload works.

How can this serious bug not be solved? Again, are other people affected by this as well?

Go to Top