Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Search not working properly


Reply

3 Posts   1162 Views

Avatar
Ryoken

19 April 2010 at 2:36pm Community Member, 18 Posts

I have an issue with the search.

I started with a clean install of Silverstripe 2.3.7
I added E-Commerce, Payment, etc.
Made a few extensions to the Product Class.

All in all nothing special.

I add my new pages, do a search, and they don't come up.
I add the same keyword I'm searching for to the default homepage, about page, etc. It still doesn't come up.
I search for a word that was already on those pages and I get results.

Debug::show of the Query and I search with it in PHPMyAdmin, I get results for old content, nothing for the new content.
The DB Fields are set to fulltext as they should, so I'm lost.

I can see the word I'm looking for right there in PHPMyAdmin, but it's not showing up when I run the query.

I'm stumped. From a logical standpoint the only thing that comes to my mind is showhow the indexes used in fulltext isn't being properly updated or something.
I haven't messed with the Search Engine code. ( even if I did the queries that should work don't )
Droping the DB and starting over didn't help.
As far as I know I haven't done anything to any pagetype or anything that could have this affect.

Does anyone have any ideas ?

Avatar
Ryoken

20 April 2010 at 12:40am Community Member, 18 Posts

Update.

Clean install of Silverstripe 2.3.7.
No Modules, custom code, or changes of any kind.

Add a word to the homepage, Search for it, no results.

Someone got some code get crossed between 2.4 and 2.3 maybe ?

Avatar
Ryoken

20 April 2010 at 1:18am Community Member, 18 Posts

Another Update.

I installed all the way back to 2.3.3 with the same result. I don't understand, I have made no changes to Wamp, and I have 2.3.3 sites on my local box that work fine.