Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SS 2.4: File Upload problems


Reply


3 Posts   2337 Views

Avatar
danzzz

Community Member, 175 Posts

15 May 2010 at 12:28am

Edited: 15/05/2010 12:58am

hi,

I have a fresh 2.4 install.

I have problems with file uploads. I cant upload png's or jpgs. After selecting the file and pressing the upload button
SS triggers this error in an alert box:

"Dies ist kein gültiger Upload" -> _t('File.NOVALIDUPLOAD', 'File is not a valid upload')

safe_mode = OFF

I have this line in _config.php:

Director::set_environment_type("dev");

but also in dev-mode I cant read out any infos from firebug console, the file requestet at this moment returns -> 200 OK

http://www.domain.com/admin/assets/getitem?ID=root&ajax=1 200 OK 564ms

does anybody have an idea what here could be wrong?

EDIT:

if I try to upload 2 files:

uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowInternal.alert]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: http://www.domain.com/admin/assets/UploadForm :: <TOP_LEVEL> :: line 8" data: no]

Line 0

daniel

Avatar
danzzz

Community Member, 175 Posts

15 May 2010 at 2:40am

http://open.silverstripe.org/ticket/5547

Avatar
vr

Community Member, 9 Posts

15 May 2010 at 11:55am

Edited: 15/05/2010 11:58am

Hi danzzz,

Please see http://silverstripe.org/installing-silverstripe/show/284108#post284108 for a description of two open issues. Did you get them resolved?

regards, vr