Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page type not recognized


Reply

2 Posts   805 Views

Avatar
Bert

28 May 2010 at 4:05am Community Member, 19 Posts

I have the following structure:

- Managed Services (Page type: TextPageHolder)
---- Dedicated servers (Page type: TextPage)
---- Hosted e-mail (Page type: TextPage)
---- Hosted SharePoint (Page type: TextPage)

I accidentally changed the class names of TextPage.php to class ActionPage and class ActionPage_Controller, and performed a /dev/build. I changed them back to class TextPage and class TextPage_Controller, but now these pages have been modified to the page type Page, and /dev/build is not picking up the page type TextPage again.

I tried adding the page type TextPage manually to the SiteTree table (enum field ClassName), but when I perform a /dev/build the page type TextPage is removed again, and the pages of the type TextPage are changed back to the page type Page.

What can I do to add the page type TextPage again?

Avatar
mark_s

29 May 2010 at 10:23am Community Member, 78 Posts

Hi.

Have you tried deleting the contents of the temp directory? This will remove all manifest artifacts, which may be confusing the issue. flush=all removes most but not all of this. Then do a dev/build again. Hopefully you can see the TextPage table in the database again. Then change the page types back. Watch that any data in the extension tables for the TextPage/ActionPage class is copied back appropriately if necessary.

Mark