Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Ubuntu 10.04


Go to End
Reply

16 Posts   3018 Views

Avatar
Mo

29 May 2010 at 4:15am Community Member, 509 Posts

Anyone on here running SIlverstripe on Ubuntu 10?

I am getting a really weird error, on a new Ubuntu 10 VPS I have setup. Basically, I cannot access /admin/cms/, it just sits on the loading screen and hangs.

No error are generated anywhere, not in the server logs, php logs, Silverstripe logs. Firebug doesn't reveal much either.

This is a site I have upgraded from 2.3 to 2.4, but it runs on my local MAMP server fine, both pre and post upgrade.

All other CMS functionality works fine.

Any ideas?

Mo

Avatar
Mo

29 May 2010 at 5:00am Community Member, 509 Posts

In terms of the Javascript errors, I am getting these:

cms:1555Unmatched </div> encountered. Ignoring tag.
LeftAndMain.js:186Uncaught TypeError: Cannot read property 'height' of undefined
iframe:5Unmatched </base> encountered. Ignoring tag.
iframe:5Unmatched </base> encountered. Ignoring tag.
iframe:5Unmatched </base> encountered. Ignoring tag.
prototype.js:1100Uncaught TypeError: Cannot call method 'match' of undefined
LeftAndMain.js:186Uncaught TypeError: Cannot read property 'height' of undefined
LeftAndMain.js:769Uncaught TypeError: Cannot set property 'display' of undefined
7editor_plugin_src.js:86Uncaught TypeError: Object #<an Object> has no method 'respondToNodeChange'
prototype.js:345Uncaught TypeError: Cannot call method 'split' of undefined
Refused to set unsafe header "Connection"
jquery.ondemand.js:177Uncaught TypeError: Object function ( selector, context ) {
   // The jQuery object is actually just the init constructor 'enhanced'
   return new jQuery.fn.init( selector, context );
} has no method 'processOnDemandHeaders'
Refused to set unsafe header "Connection"
jquery.ondemand.js:177Uncaught TypeError: Object function ( selector, context ) {
   // The jQuery object is actually just the init constructor 'enhanced'
   return new jQuery.fn.init( selector, context );
} has no method 'processOnDemandHeaders'
Refused to set unsafe header "Connection"
jquery.ondemand.js:177Uncaught TypeError: Object function ( selector, context ) {
   // The jQuery object is actually just the init constructor 'enhanced'
   return new jQuery.fn.init( selector, context );
} has no method 'processOnDemandHeaders'

Some don't look to nice, I don't know enough about all of SilverStripes ajax stuff to make head nor tails of them to be honest.

Mo

Avatar
biapar

1 June 2010 at 12:37am Forum Moderator, 435 Posts

Permission on folder?

I've used Ubuntu 9.04 and Win2k8 IIS 7.5 WinCache ( now ) without problems..

Avatar
mark_s

1 June 2010 at 11:37am Community Member, 78 Posts

Hi.

I have 2.4 running fine on Ubuntu 10.04.

Have you made sure that sapphire and cms have been replaced (i.e. 2.3 files removed, not lingering). Same goes for jsparty, which is not in 2.4 any more.

Mark

Avatar
Mo

1 June 2010 at 8:52pm Community Member, 509 Posts

Not permissions (as far as I can tell), have tried doing a chown recursive on all files and folders, also tried running as a different user (using the mpm_itk apache module).

All files are definatly 2.4, I use a python based deployment script that removes all of the old files before running an update.

I am trying to get an old version of the database and try running an update again, I will post back my results. It seems very odd though :s.

Mo

Avatar
Mo

1 June 2010 at 9:24pm Community Member, 509 Posts

Ok, I have tracked this issue to something to do with CMS Workflow (sorry, I neglected to mention I am using this).

I have upgraded to RC4, but something is causing weirdness.

Anyway, I think I will post a new topic under the Workflow module instead.

Cheers for your help,

Mo

Avatar
jam13

1 June 2010 at 9:35pm 121 Posts

Lucid is PHP 5.3, is SilverStripe fully compatible with 5.3 (including all the modules)?

I've had to pull in php libs from Karmic on my dev box as quite a few of the libs that I'm using are not compatible.

Avatar
Mo

1 June 2010 at 10:02pm Community Member, 509 Posts

Interesting, I didn't know that.

Wouldn't a compatibility problem raise an error, either from PHP or Apache though?

Mo

Go to Top