Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

None of these templates can be found in theme Error


Reply


5 Posts   2823 Views

Avatar
otherjohn

Community Member, 125 Posts

4 June 2010 at 1:46am

I turn on widgets in the blog and get this error.

None of these templates can be found in theme 'v1': Widget.ss, DataObject.ss, ViewableData.ss, Object.ss
Line 191 of SSViewer.php

I have run a dev/build
and flushed

no luck!

Avatar
swaiba

Forum Moderator, 1799 Posts

4 June 2010 at 2:33am

I know this... I raised ticket on it this morning!

Translation : You have a widget that is assigned to that page that has wither been removed or renamed.

Goto the page that gives the error in the Site Content / Pages and see what widgets are there... the one the system no longer can find will be named 'Name of this Widget'.

Just to set your mind at ease - you only see this error with the site is not in "live" mode.

Barry

Avatar
otherjohn

Community Member, 125 Posts

4 June 2010 at 2:37am

Sweet. Now I can track it down better. Thanks!

Avatar
joshy

Community Member, 57 Posts

8 June 2010 at 6:18am

Thanks, this really helped me too :-)

Avatar
Garrett

Community Member, 245 Posts

10 May 2011 at 1:39am

All you have to do to fix this error is go to the Blog Holder in the CMS, go to Widgets tab, delete the empty instances that are there, and then re-add.

//Garrett