Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[SOLVED] CMS doesn't load after switch from dev to live


Reply

7 Posts   1288 Views

Avatar
atticusservices

9 June 2010 at 4:05pm (Last edited: 11 June 2010 9:19am), Community Member, 10 Posts

CMS never finishes loading. It hangs on the "Loading..." overlay. Upon a closer look, I noticed my browser error log saying "Can't find variable: jQuery". I then realized the CMS isn't loading half the javascript it should be. If it set "Director::set_environment_type('dev');", then everything loads fine. Remove it and it breaks.

I've been working on this for 4hrs. If anyone can point me in the right direct, I would really appreciate it.

Thanks

Avatar
Willr

9 June 2010 at 5:23pm Forum Moderator, 5511 Posts

Its probably to do with the concatenation of files in live mode. Try adding this to your _config.php file.

Requirements::set_combined_files_enabled(false);

Avatar
atticusservices

9 June 2010 at 5:28pm Community Member, 10 Posts

Thanks. That is a better solution than what I ended up doing.... commenting out all the "combined_files" code in LeftAndMain.php :)

Avatar
dizzystuff

11 June 2010 at 9:07am Community Member, 93 Posts

FYI I just had the same issue. Couldn't get into admin when not in dev mode. Willr's addition to _config.php did the trick.

Avatar
Willr

11 June 2010 at 7:22pm Forum Moderator, 5511 Posts

@both of you - what modules did you have (if any). What I suspect is that you upgraded to 2.4 and it used older 2.3 javascript files. Or it could be a module (userforms) which is affecting it.

Avatar
dizzystuff

13 June 2010 at 1:31pm Community Member, 93 Posts

Hey Willr

I'm using some latest builds from the repo...

SilverStripe /branches/2.4 [rev 105726]
+ Blog /tags/0.4.0 [rev 105888]
+ Userforms /tags/0.3.0 [rev 105956]
+ DataObject_Manager /trunk [rev 395]
+ swfUpload /trunk [rev 375]
+ Event_Calendar /trunk [rev 110]
+ SecureFiles /trunk [rev 145]

+ a bunch of my own modules, widgets and an extension -> but none of these add/use/rely-on old/new js

Avatar
TheDust

15 December 2010 at 9:27am Community Member, 3 Posts

hi there,

i have the same problem but it does not load not only the java scripts it says

Message: 'Behaviour' is undefined
Line: 552
Char: 1
Code: 0
URI: http://www.cocukcaisler.com/admin

i tried to configure the _config.php as you told, but it didn't work.

please help me. i didnt install anything. i just installed silverstripe and i was creating the page but at the second time i try to login i crashed. please help me...