Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Static Sidebar Tutorial : Database table not created


Reply

3 Posts   1256 Views

Avatar
ivegg

1 July 2010 at 2:07am Community Member, 7 Posts

Hello all

I followed the tutorial for the sidebar on http://www.ssbits.com/create-a-static-sidebar/ . It seems that if apply dev/build?flush=1 that the database is not affected. The interface shows all built tables and says "Database build completed"!. But i cannot see any new table created, only the existing ones. Do you know what i am doing wrong?

Thanks for your help
-ivegg

Avatar
Howard

1 July 2010 at 3:32pm Community Member, 215 Posts

It could be a number of things, it would be best if you post the code that you are using to a site like http://pastie.org/ and provide us a link.

Some of the things to check are making sure the files are named correctly and in the right place etc...

Avatar
ivegg

1 July 2010 at 7:18pm (Last edited: 1 July 2010 7:23pm), Community Member, 7 Posts

Hello

Thanks for your answer. I did everything exactly as mentioned in the tutorial. Went through it at least 3 times. If it's useful to you: im using Silverstripe 2.4.

howardgrigg, could you quickly look at the code in the tutorial? Do you think anything is wrong with that?
Thanks a lot

-Ivan