Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

"Error Saving Content" - triggered by using words "select" & "from" in content


Go to End
Reply


13 Posts   3226 Views

Avatar
MateuszU

Community Member, 89 Posts

27 September 2010 at 2:49pm

Nah, I'm not a sysadmin, so won't be able to help you there. Try different approach, add this to your _config.php:

SS_Log::add_writer(new SS_LogEmailWriter('your@email.address.it'), SS_Log::ERR);

You should get the error message into your inbox.

Mateusz

Avatar
socks

Community Member, 191 Posts

27 September 2010 at 2:53pm

I have that in my _config. I do receive errors in general, just not for this scenario.

Thanks for the effort, I appreciate it.

Avatar
MateuszU

Community Member, 89 Posts

29 September 2010 at 9:45am

Hmm so it looks like the error is not coming from SilverStripe layer, since you are in dev mode and have emails enabled.

I think my next step in this case would be to hijack the query function call (probably in MySqlDatabase.php) and add some logging mechanism to dump all the executed queries (firebug, var_dump, or write to a file). Then you can have a look through raw queries and find the last one before the server crashes (probably the UPDATE one that stores the "select from" thing, right?).

Then you could try this query in phpMyAdmin directly to see if it's something with the query itself.

Mateusz

Avatar
Jonn

Community Member, 10 Posts

20 December 2010 at 5:25pm

I'm running SS 2.4.3 and I'm having a similar issue anytime the word select or from is in the content I am trying to save it causes an Error Saving Content message and an 500 Internal Server Error tried the patch mentioned in this thread but that does not solve the problem.

Anyone else run into this problem?

Avatar
figjam

Community Member, 10 Posts

2 September 2013 at 9:45am

Yes, using Silverstripe 3, I was having a similar problem - my CMS was returning "Internal Server Error" whenever I try to save any page containing the words "select" and "from".

You need to get your hosting provider to fix their Web Application Firewall (WAF) which is blocking certain CMS inserts into your DB. See - http://www.silverstripe.org/general-questions/show/20010,

Go to Top