Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Paragraph tags in TinyMCE


Reply

2 Posts   2194 Views

Avatar
Snowlord

14 August 2010 at 5:08am (Last edited: 14 August 2010 5:09am), Community Member, 6 Posts

I have a custom content field built and everything is working fine, except that the TinyMCE automatically plugs in <p> </p> before and after any copy or code I add. This is really messing up the flow of the site! I've cycled through all the other formats (address, H1, H2, etc.) and all put some sort of formatting tag in front and behind my text. If I edit the HTML and delete them, TinyMCE just plugs them back in after I save it. How can I stop TinyMCE from automatically adding these formatting tags??

Thanks!

Avatar
Devlin

14 August 2010 at 9:45pm (Last edited: 14 August 2010 9:54pm), Community Member, 215 Posts

[url=http://www.silverstripe.org/general-questions/show/289848]Re: content I put into TinyMCE in the CMS is automatically warpped ina <p> tag. How do I stop this?[/url]

"Any help would be great"

http://lmgtfy.com/?q=tinymce+p+tag

HTML Editor Config - Setting TinyMCE Options:
http://doc.silverstripe.org/htmleditorconfig#setting_tinymce_options_eg_valid_elements

---

Edit:
If you want just the custom content field without any p tags, you could also do:

function CustomContent() {
return str_replace( array("<p>","</p>"), array("",""), $this->CustomContent );
}