Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Translated content -> Page blank


Reply


3 Posts   756 Views

Avatar
oleze

Community Member, 65 Posts

8 August 2010 at 5:54am

When I click on my "show this page in English" button, I get only blank pages. My German translations (standard) are working fine.
PHP Logs the following error:

[07-Aug-2010 19:50:17] PHP Fatal error: Call to a member function XML_val() on a non-object in /private/var/folders/zi/ziF2WYoKHjuWeyujYsvSBU+++TI/-Tmp-/silverstripe-cache-Users-username-Sites-project/.cache.Users.username.Sites.project.themes.themename.templates.Page.ss on line 119

But because there are layoutspecific details and includes, there is no line 119 on Page.ss

Avatar
swaiba

Forum Moderator, 1805 Posts

8 August 2010 at 6:12am

What version of SS are you using and is it in "dev" mode?
I've been having strange errors with the word cache in lately - they all disappear once the site is "live".

Avatar
oleze

Community Member, 65 Posts

8 August 2010 at 6:32am

I'm using 2.4.1 in dev-mode. Actually, I figured what's the problem. I'm using the CustomMenus Module for adding a topnavigation on my page. Seems it doesn't support the translation, when I comment it out, the pages show up. Damn.