Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Files & Images Website Error - server has not been able to respond


Reply


3 Posts   1005 Views

Avatar
Gina

Community Member, 11 Posts

29 July 2010 at 7:15am

Hello,
Getting the subject error when I hit the upload files button in the files & images/upload tab.

I am simply trying to get a flash .swf, an .xml file and some images to upload. I can upload all this manually via ftp but the only way I can get SS to see some of these files after upload is by going back and forth between the site content and files and images tabs (found this workaround elsewhere on this site). This is not working for the .xml or .swf for some reason.

On another thread someone suggested changing permissions. I am not a developer but am really good at copying and pasting the development of others! If someone could tell me exactly what code, in what file/folder to change I'd be really grateful - I am a mere designer abandoned by her flake-oid developer!

THANKS IN ADVANCE!!!! Here is the full error:

[Warning] copy(/home/www/sites_on_nfs/public/radimage/htdocs/assets/xml/chibetiba.jpg) [function.copy]: failed to open stream: Permission denied
POST /admin/assets/UploadForm

Line 195 in /usr/home/www/sites_on_nfs/public/radimage/htdocs/sapphire/filesystem/Folder.php
Source

186       Filesystem::makeFolder(dirname("$base/$file"));
187       
188       while(file_exists("$base/$file")) {
189          $i = isset($i) ? ($i+1) : 2;
190          $oldFile = $file;
191          $file = ereg_replace('[0-9]*(\.[^.]+$)',$i . '\\1', $file);
192          if($oldFile == $file && $i > 2) user_error("Couldn't fix $file with $i", E_USER_ERROR);
193       }
194       
195       if(file_exists($tmpFile['tmp_name']) && copy($tmpFile['tmp_name'], "$base/$file")) {
196          // Update with the new image
197          return $this->constructChild(basename($file));
198       } else {
199          user_error("Folder::addUploadToFolder: Couldn't copy '$tmpFile[tmp_name]' to '$file'", E_USER_ERROR);
200          return false;
201       }

Trace

* copy(/var/tmp/phpTMn125,/home/www/sites_on_nfs/public/radimage/htdocs/assets/xml/chibetiba.jpg)
Line 195 of Folder.php
* Folder->addUploadToFolder(Array)
Line 219 of AssetAdmin.php
* AssetAdmin->doUpload(Array,Form,HTTPRequest)
Line 228 of Form.php
* Form->httpSubmission(HTTPRequest)
Line 107 of RequestHandler.php
* RequestHandler->handleRequest(HTTPRequest)
Line 121 of RequestHandler.php
* RequestHandler->handleRequest(HTTPRequest)
Line 122 of Controller.php
* Controller->handleRequest(HTTPRequest)
Line 277 of Director.php
* Director::handleRequest(HTTPRequest,Session)
Line 121 of Director.php
* Director::direct(admin/assets/UploadForm)
Line 115 of main.php

Avatar
Willr

Forum Moderator, 5513 Posts

29 July 2010 at 10:49pm

[Warning] copy(/home/www/sites_on_nfs/public/radimage/htdocs/assets/xml/chibetiba.jpg) [function.copy]:

You might want to check the permissions on the assets folder. Your webserver user (apache or www-data) will need to be able to read / write the directly. You can fix this by running something like chmod -R 666 on the assets folder (Read + Write recursively). You should be able to fix this using your FTP program under permissions.

Avatar
Gina

Community Member, 11 Posts

31 July 2010 at 12:58am

Thanks - I'll give it a shot!