Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

content not saving


Reply


15 Posts   2453 Views

Avatar
Scorpiankh

Community Member, 60 Posts

26 July 2010 at 1:53pm

there's no custom code in the controller.

as far as I can tell permissions are ok but it's a windows server, never used a windows server before and I think the permissions are setup completely different to a Linux server .. still getting the hang of it.

Avatar
Scorpiankh

Community Member, 60 Posts

27 July 2010 at 9:36am

Is there anything I can do to help determine what's causing the problem?

Avatar
Scorpiankh

Community Member, 60 Posts

27 July 2010 at 2:53pm

I just tried to add content in the CMS using IE instead of Firefox and got this error:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; Tablet PC 2.0; .NET CLR 3.5.30729; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; .NET CLR 3.0.30729; .NET4.0C)
Timestamp: Tue, 27 Jul 2010 02:51:14 UTC

Message: 'undefined' is null or not an object
Line: 7433
Char: 4
Code: 0
URI: http://etherealart-co-nz.mccoy.techservers.net/jsparty/tiny_mce2/tiny_mce_src.js?m=1279529684

Message: Object doesn't support this property or method
Line: 86
Char: 11
Code: 0
URI: http://etherealart-co-nz.mccoy.techservers.net/jsparty/tinymce_ssbuttons/editor_plugin_src.js?m=1279529684

Avatar
mathiasmex

Community Member, 28 Posts

28 July 2010 at 9:22am

Hi Scorpiankh,

had the same issue right now after upgrading to 2.4.1
Following steps helped me out:

Check in the Databasetable "SiteTree" that all entries have a ClassName defined. If not, add the corresponding ClassName manually.
In mysite/code, check that no "CalendarDateField" is defined in any function (e.g. getCMSFields). If so, just rename it to "DatePickerField".
Log into the CMS, go to the Behaviour tab and check if all pages show the appropiate Pagetype. Finally, make sure that all pages have some content. The pages I could not save did not have any content. By just including "Lorem Ipsum" to the content area, they saved without problem.

Seems that on some point upgrading to 2.4, erases some ClassName fields in Databasetable and causes some Pages to show up as "Pageytpe:SiteTree", which should not be.

Hope this helps.

Avatar
Scorpiankh

Community Member, 60 Posts

28 July 2010 at 4:14pm

Thanks for the reply.
I tried what you suggested but still cannot save any content.

Avatar
Scorpiankh

Community Member, 60 Posts

29 July 2010 at 2:34pm

I'm still no closer to solving this problem, can anyone help?

Avatar
Scorpiankh

Community Member, 60 Posts

29 July 2010 at 5:44pm

Edited: 29/07/2010 5:52pm

So I've been playing around a bit more and looking at the database table for sitetree, I've found if i edit the data in the content field directly from the database and save that it will save in the database and shows up on the page on the website.
However if i then go into the CMS and edit the content for that same page it will overwrite what I wrote in the database with <p></p>.
So it appears the write command is being executed, it's just losing the data that's supposed to be written.
And it seems to be restricted entirely to the content field