Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Nasty error on home page only


Reply


2 Posts   855 Views

Avatar
Mitz

Community Member, 10 Posts

20 July 2010 at 11:53am

Edited: 20/07/2010 12:09pm

Hi guys,

Have a nasty error showing up just for the home page I'm working on with Silverstripe. Friendly error just says: website server could not respond to your request: www.fxmed.co.nz/silverstripe/

Other pages within the site working fine, eg. http://www.fxmed.co.nz/silverstripe/nordic-naturals/

Below is the error I get on the home page when I plug in http://www.fxmed.co.nz/silverstripe/?isDev=1.

Any ideas? Thanks for your help.

User Error] Couldn't run query: SELECT `SiteTree_Live`.*, `Page_Live`.*, `BlogEntry_Live`.*, `SiteTree_Live`.ID, if(`SiteTree_Live`.ClassName,`SiteTree_Live`.ClassName,'SiteTree') AS RecordClassName FROM `SiteTree_Live` LEFT JOIN `Page_Live` ON `Page_Live`.ID = `SiteTree_Live`.ID LEFT JOIN `BlogEntry_Live` ON `BlogEntry_Live`.ID = `SiteTree_Live`.ID WHERE (ParentID = ) AND (`SiteTree_Live`.ClassName IN ('BlogEntry')) ORDER BY Date DESC LIMIT 4 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND (`SiteTree_Live`.ClassName IN ('BlogEntry')) ORDER BY Date DESC LIMIT 4' at line 1
GET /silverstripe/?isDev=1

Avatar
Mitz

Community Member, 10 Posts

20 July 2010 at 12:10pm

Ignore the above! Fixed now....unbelievable! It was simple as the home page not being properly published through the cms.