Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Fatal error: Allowed memory size of 67108864 bytes exhausted


Reply

5 Posts   3962 Views

Avatar
clintonf

2 October 2010 at 7:07pm Community Member, 8 Posts

Hi does anyone have a solution to the following: I have read through other archives however the fix suggested there does not work....

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 194174 bytes) in /var/www/vhosts/puregaynz.com/httpdocs/sapphire/core/Requirements.php on line 630

Hope someone can assist.

Avatar
Bruce B

6 October 2010 at 2:34pm Community Member, 145 Posts

You need to increase the memory allocation for PHP. How you do that depends on your hosting arrangements. here is a page describing the process for my host, Jumba

cheers
bruce

Avatar
cuSSter

7 October 2010 at 2:29am Community Member, 56 Posts

Hi,

Hope this helps. In your php.ini file, find max_execution_time and set it to something bigger. :)

Avatar
swaiba

7 October 2010 at 2:44am Forum Moderator, 1796 Posts

you could place...

ini_set('memory_limit','1000M');

...in your _config.php if safe mode allows you, then you don't need to change server settings

Avatar
martinlebel

9 May 2013 at 6:15am Community Member, 1 Post

I was getting this error because I un-commented the following values in php.ini. to trouble shoot another http500 error

Can someone can explain why uncommenting thoses value give me the
"Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in /var/DEV/www-v4.1/ss/sapphire/core/Object.php on line 652"

and

"Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 80 bytes) in /var/DEV/www-v4.1/ss/sapphire/core/model/DataObject.php on line 350" ?

; display_errors
Default Value: On
Development Value: On
Production Value: Off

; display_startup_errors
Default Value: Off
Development Value: On
Production Value: Off

; error_reporting
Default Value: E_ALL & ~E_NOTICE
Development Value: E_ALL | E_STRICT
Production Value: E_ALL & ~E_DEPRECATED

; html_errors
Default Value: On
Development Value: On
Production value: Off