Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Issue with assets directory on windows server


Reply


5 Posts   1150 Views

Avatar
infused

Community Member, 5 Posts

19 October 2010 at 3:15pm

Hi there,

Running latest version of SilverStripe using the web installer for Windows. Windows Platform is Windows 2008R2 with PHP and MSSQL 2008R2 Express.

Everything is fine apart from one thing. Any image in the assets directory is producing a error 500 message. I have been looking around and I believe this might be a php issue.

Could anyone help with this?

Avatar
Sean

Forum Moderator, 922 Posts

19 October 2010 at 4:29pm

Edited: 19/10/2010 4:34pm

Hi there,

Please confirm that the assets directory has appropriate permissions for the web server to write.

You can check this on the Security tab when right clicking "assets" and going to Properties. In that Security tab, there should be an IUSR entry listed there which has write permissions.

You can also force IIS to reveal error messages by doing the following:

1. Open Internet Information Services (IIS) Manager
2. Click your server name on the left hand Connections panel
3. Double click the Error Pages icon on the right
4. Click Edit Feature Settings on the right hand sidebar
5. Click Detailed errors in the radio button listing then click OK
6. Restart IIS by going back to the server name in the left hand Connections panel and clicking Restart on the right hand sidebar

This should at least stop the annoying generic IIS errors, and you'll get a detailed error message which should give you some leads.

If you get an error message and are not sure how to solve it, paste it in this thread and we can see what we can do.

Good luck!

Sean

Avatar
infused

Community Member, 5 Posts

19 October 2010 at 4:46pm

Ok,

Done. The files are getting uploaded, it's when viewing them I get the error. Even with detailed reporting on, I get the following message:

The page cannot be displayed because an internal server error has occurred.

Avatar
infused

Community Member, 5 Posts

20 October 2010 at 9:04pm

I have figured it out. urlrewrite error due to permissions. When a file is uploaded, iss_usrs user is being given special permissions (which dont allow it to be read.) Correctly setting the permissions manually fixes the issue. Any way to fix this?

Avatar
jbhainsworth

Community Member, 2 Posts

23 March 2011 at 12:07pm

What did you do to correctly set the permissions manually? and was that for the single upload or the assets folder?