Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[Warning] include(C:\wamp\www\aoa/silverstripe-cache/.cacheC..wa...... on ine 392 in C:\wamp\www\aoa\sapphire\core\SSViewer.php.... include($cacheFile);


Reply


4 Posts   1155 Views

Avatar
swaiba

Forum Moderator, 1804 Posts

30 October 2010 at 11:50pm

Edited: 30/10/2010 11:51pm

Hi,

Randomly I am getting the following error while in dev mode, everything is fine when I switch to live...

[Warning] include(C:\wamp\www\aoa/silverstripe-cache/.cacheC..wamp.www.xxxxxx.themes.xxxxxxxxx.templates.Page.ss) [function.include]: failed to open stream: No such file or directory
GET /aoa/xxxxxxxxxxxx

Line 392 in C:\wamp\www\aoa\sapphire\core\SSViewer.php

Source

383                $subtemplate => $subtemplateViewer->process($item, $cache)
384             ));
385          }
386       }
387       
388       $itemStack = array();
389       $val = "";
390       $valStack = array();
391       
392       include($cacheFile);
393
394       $output = $val;      
395       $output = Requirements::includeInHTML($template, $output);
396       
397       array_pop(SSViewer::$topLevel);
398
Trace

SSViewer::process
Line 392 of SSViewer.php
SSViewer->process(BillingPage_Controller)
Line 202 of Controller.php
Controller->handleAction(SS_HTTPRequest)
Line 134 of RequestHandler.php
RequestHandler->handleRequest(SS_HTTPRequest)
Line 147 of Controller.php
Controller->handleRequest(SS_HTTPRequest)
Line 199 of ContentController.php
ContentController->handleRequest(SS_HTTPRequest)
Line 283 of Director.php
Director::handleRequest(SS_HTTPRequest,Session)
Line 127 of Director.php
Director::direct(/xxxxxxxxxxxxxx)
Line 127 of main.php

could it be related to this in my config that should automatically flush the site?

if (Director::isDev()) {
   ini_set('display_errors', 1);
   error_reporting(E_ALL);
   SSViewer::flush_template_cache();
   Debug::log_errors_to('err.log');
}

..any ideas?

Avatar
Willr

Forum Moderator, 5513 Posts

31 October 2010 at 12:50pm

could it be related to this in my config that should automatically flush the site?

Remove it and see if the site works :D

It could also be a permissions issue, check to see the web user has read / write access to the silverstripe-cache folder.

Avatar
swaiba

Forum Moderator, 1804 Posts

1 November 2010 at 10:14pm

I will as you sensibly suggest remove it, this is a snippet from ssbits so I figured someone else may have seen this while using the code.

Avatar
swaiba

Forum Moderator, 1804 Posts

2 November 2010 at 4:00am

well removing...

if (Director::isDev()) {
SSViewer::flush_template_cache();
}

...has worked, I'll comment on the new ssbits link when my password reminder comes through. Shame though as it is bally useful to have the templates flushed each time without having to add anything to the url...