Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page not fully loaded


Go to End
Reply

22 Posts   2373 Views

Avatar
OBITS

4 November 2010 at 1:05am (Last edited: 4 November 2010 1:06am), Community Member, 17 Posts

Hi Forum

I write because I have some Problems with my website. If I load the website with path example www.example.org/example then all is okay. (Themes, Pictures etc)
If I change my apache settings to directaccess example www.example.org the website show me only good old html style an now pictures.

can you help me.
thx

OB

Attached Files
Avatar
cuSSter

4 November 2010 at 1:43am Community Member, 56 Posts

Hi Obits,

Hmm, I haven't tried changing Apache settings to direct access like what you did. I assume you're in dev mode right? I have another way though, through .htaccess. Add this line of codes to your .htaccess.

RewriteRule ^example$ / [L,R=301]

Avatar
OBITS

4 November 2010 at 5:09am Community Member, 17 Posts

Thx Pinoy_SS for your input... but the problem is, that must make more than one Aliases for this website so i need the apache.

Avatar
cuSSter

4 November 2010 at 6:28am Community Member, 56 Posts

Oh. Haven't tried that one yet. Just a question, is the URLSegment 'example' is your index/home page?

Avatar
mmh

4 November 2010 at 9:52am (Last edited: 4 November 2010 9:53am), Community Member, 24 Posts

Take a look at your base href (looks currently like "<base href="http://www.example.com/index.php/"></base>"). This is the reason why no images will be displayed on your page. You're also requesting CSS in this way:

<link rel="stylesheet" type="text/css" href="http://www.example.com/index.php/themes/higherground/css/typography.css?m=1201468536" />


But Silverstripe can't find these files (if you take a look at the standard htaccess you know what I mean).
Fix this issue and you'll be able to see your website in the correct way.

Avatar
OBITS

4 November 2010 at 8:41pm Community Member, 17 Posts

Thx Timo, but i am absolutbeginner in php. So what i can see in htaccess is

### SILVERSTRIPE START ###
<Files *.ss>
   Order deny,allow
   Deny from all
   Allow from 127.0.0.1
</Files>

<Files web.config>
   Order deny,allow
   Deny from all
</Files>

<IfModule mod_rewrite.c>
   RewriteEngine On
   RewriteBase /schrittederHoffnung
   RewriteCond %{REQUEST_URI} ^(.*)$
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>

### SILVERSTRIPE END ###

so what i is to correct?

Avatar
OBITS

4 November 2010 at 8:57pm Community Member, 17 Posts

Maybe intressting, when i correct define('BASE_SCRIPT_URL','index.php/'); to define('BASE_SCRIPT_URL',''); i have the my website layout, but the website functioned not

Avatar
mmh

4 November 2010 at 9:16pm Community Member, 24 Posts

Change

define('BASE_SCRIPT_URL','index.php/');


to

define('BASE_SCRIPT_URL','/');

Go to Top