Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Mod_Rewrite


Reply

3 Posts   830 Views

Avatar
Roony

3 December 2010 at 8:25am Community Member, 14 Posts

I have a new install of SS2.4 and it all works properly, however when I delete /index.php from the url it gives me a 500 error. When I add index.php back the site works fine. This means that every page has /index.php in front of it, which i need to get rid of.

the site is www.locodesigns.com.au

but you will only be able to see it properly at www.locodesigns.com.au/index.php

Is this something to do with mod_rewrite? and if so how do I fix it on my webserver? Or is it another problem that I will be able to look into? Any ideas anyone?

Avatar
Sean

3 December 2010 at 8:40am (Last edited: 3 December 2010 8:43am), Forum Moderator, 921 Posts

This usually means mod_rewrite isn't enabled.

You could also ask your host for any logs which may shed light on the 500 server error.

Could you paste in your .htaccess file here?

Avatar
greenpea

18 May 2011 at 8:56pm (Last edited: 18 May 2011 9:17pm), Community Member, 19 Posts

I had the same problem and my .htaccess file was empty - no content at all.

This thread http://www.silverstripe.org/installing-silverstripe/show/16895 sorted it out, now index.php no longer shows