Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Stuck in tutorial 1


Reply


2 Posts   451 Views

Avatar
Chontell

Community Member, 1 Post

24 March 2011 at 12:18am

Hello,

I am very new to Silverstripe and have not used a CMS before but I am keen to learn.

I am currently stuck on creating a second menu in tutorial one, all my code looks the same as in the tutorial however when i publish my site this does not show however the second menu shows in the draft?

Can anyone help me please?

This is my code below:

<div id="Main">
      
<ul id="Menu1">
<% control Menu(1) %>
<li class="$LinkingMode">
<a href="$Link" title="Go to the &quot;{$Title}&quot; page">$MenuTitle</a>
</li>
<% end_control %>
</ul>
   
<div id="Header">
<h1>$Title</h1>
</div>         

<div id="ContentContainer">

<% if Menu(2) %>
<ul id="Menu2">
<% control Menu(2) %>
<li class="$LinkingMode"><a href="$Link" title="Go to the &quot;{$Title}&quot; page">$MenuTitle</a></li>
<% end_control %>
</ul>
<% end_if %>

      
<div id="Content" class="typography">

<% if Level(2) %>
<div class="breadcrumbs">
$Breadcrumbs
</div>
<% end_if %>
            
$Content
               
$Form
            
</div>
   
</div>
   

Many thanks

Chontell

Avatar
cumquat

Community Member, 198 Posts

24 March 2011 at 4:06am

Hi ya,

Welcome to Silverstripe.

Did you remember to dev/build?flush=1 and or flush the cache ?flush=1

Mick