Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

CHARACTER SET 'utf8' error


Reply

15 Posts   3498 Views

Avatar
midoriberlin

28 March 2012 at 11:51pm Community Member, 5 Posts

Hello all,

A little late but this might help someone. I was getting exactly the same error, not locally but after I uploaded to a live site.

Afterwards I realised what was happening was I had an admin window open in my local environment which, due to checking out a different version of the site to push to live, was unable to security ping to the correct address.

And so I get this error every minute while that was the case. Check the subject of the email you get and see if it has anything about "security ping" in it and if so a variation on the scenario above may be the problem.

cheerio,

a

Avatar
borriej

6 April 2012 at 6:50am Community Member, 267 Posts

I am also getting this error.

I had a live site transferred from one hosting to another. At previous hosting it ran perfectly.. but now, i receive this error. mysite/_config.php is set to connect to the correct database.

Any idea's?

[05-Apr-2012 08:29:14] Error at sapphire/core/model/MySQLDatabase.php line 525: Couldn't run query:
SET CHARACTER SET 'utf8'

Avatar
borriej

6 April 2012 at 8:29am Community Member, 267 Posts

typo in password.. solved

Avatar
oleze

9 April 2012 at 2:33am Community Member, 65 Posts

Seems on my local development systems (MAMP) the error came from using "localhost" as a alias for my database-server. Changed it to "127.0.0.1" and the error is gone.

Avatar
techgyver

7 June 2012 at 6:51am Community Member, 6 Posts

I just had the same issue. The error was caused by too many mysql-connections, so i increased the limit and solved the problem.

Avatar
AdamJ

9 June 2012 at 5:18pm Community Member, 145 Posts

@techgyver - how did you do that?

Avatar
mikeyc7m

29 April 2014 at 11:36am Community Member, 4 Posts

I'm seeing the error too. It only occurs when the static 404 error page is hit, which is weird because it's static.
I'm guessing it's a problem with the code used to serve or regenerate the static error pages and it does not reference the _config.cfg to use the correct database character set - as defined by this line:
MySQLDatabase::set_connection_charset('utf8');
I'm only seeing the bug on my 2.4 site.