Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Not able to upload image files

Go to End

5 Posts   2043 Views


Community Member, 7 Posts

4 April 2011 at 2:31pm

I'm a recent convert to using SS and I've been very impressed with how fast I have been able to port over an old site and get it functional while using XAMPP. However, I have encountered an issue that I am currently unable to resolve, though I have found a possible workaround solution.

I set up a development site for experimentation, and installation has been a success. I am however, unable to upload any image files, as the system reports an error, stating "File is not a valid upload" and "There is nothing to upload". As a temporary workaround, I've already read about the "Look for new files" function, and I intend to test this by uploading the images via FTP, but I would like to resolve this issue nevertheless.

I've read another thread on this forum dated 2 months prior that seems to solve the issue, but the resolution involves a patch file that looks like it was made by a 3rd party, and I am notoriously sticky about being able to trust stuff that I download. Aside from this, my own webhost has several security restrictions in place which I have already modified to allow SS to do its work.

Any suggestions/advice?


Community Member, 135 Posts

5 April 2011 at 9:12pm

Edited: 05/04/2011 9:12pm

It might be this problem?

Should be fixed in 2.4.5, though.


Community Member, 7 Posts

6 April 2011 at 2:13pm

That's odd. My image files don't have upper case letters in the file extension. Also, I am using 2.4.5 currently.

I've managed to work around the issue by taking advantage of the "Look for New Files" function, but it's a bit troublesome to do so. I'd much rather find a way to enable file uploads within the system than work around it.


Community Member, 130 Posts

6 April 2011 at 3:52pm

Maybe something to do with permissions? See

If you can edit permissions from your FTP client try changing permissions for the assets folder to '777' and make it recursive so it applies that to all folders/files inside the assets folder.


Community Member, 7 Posts

6 April 2011 at 4:15pm

Changing permissions will not be an issue as I can do it using SSH. However, I understand that making such a change may make the system highly insecure. Is this a SS requirement (having the asset folder with full read/write permissions) and how will this affect the security of the rest of the site?