Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Notepad++ question


Reply

6 Posts   1902 Views

Avatar
Graphicator

6 April 2011 at 1:58pm Community Member, 62 Posts

I use Notepad++. I also know when and when not to use Dreamweaver. When I want to associate a .ss file with html syntax coloring, Dreamweaver accepts filetype changes to assist you while developing with that file type.

I am asking if anyone knows how to associate .ss with Notepad++ as html? Right now I have to change the 'language' manually to help me with syntax coloring.

-Thanks

Avatar
wmboy

10 May 2011 at 12:56pm Community Member, 3 Posts

Anyone find out a solution to this? Would make editing in Notepad++ a whole lot quicker!

Avatar
swaiba

11 May 2011 at 3:44am Forum Moderator, 1796 Posts

I've never done it but googled out of curiosity. I use TextPad instead it's much faster and integrates tons more customization of tools.
anyway...

http://allthingsmarked.com/2009/07/29/associate-file-extensions-with-specific-languages-in-notepad-plus-plus/

Avatar
wmboy

11 May 2011 at 10:25am Community Member, 3 Posts

Thanks for your response. Unfortunately after following these instructions, and restarting Notepad++ it's still not working. Have attached a screenshot to show you my updated settings.

Attached Files
Avatar
Wyman

14 May 2011 at 3:07am Community Member, 9 Posts

The posted instructions are right but you still have a conflict. The problem is that ss files are detected as Scheme files by default and that setting is getting in the way of your user set setting. Therefore you need to get rid of that default, there isn't a nice way to do this inside N++ that I could find. I did find this post on stack overflow though:
[url]http://superuser.com/questions/58672/how-to-set-the-default-language-in-notepad[/url]
The post by 'Mike Chess' gave me the answer:
In the Notepad++ directory look for the langs.xml file.

<Language name="scheme" ext="scm smd ss" commentLine="">

Delete the 'ss' and the one you set via N++'s GUI will work. Don't forget to save (and make sure to not edit it with N++...).

Restart Notepad++ Open a .ss file. It should be formatted as HTML now (if you did what was posted in the previous post by swaiba).

Cheers!

Avatar
RBG

1 November 2012 at 3:41pm Community Member, 1 Post

I know this thread is long dead... but thanks... I spent ages trying to work out why ss files would not show up as html files.