Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Embed problem!


Reply

22 Posts   3674 Views

Avatar
LostBalloon

18 April 2011 at 7:39am Community Member, 16 Posts

Ok,
i had tried making a new folder and adding it there with the same result, (had to test for the heck of it)

since you mentioned file permissions, i decided to take a look at the File table in the database, and this record has some differences from the others, so it might just be file permissions as you mentioned.

Attached Files
Avatar
LostBalloon

18 April 2011 at 1:20pm Community Member, 16 Posts

Note: I'm even getting a 403 Forbidden on images that I am importing.

Avatar
martimiz

18 April 2011 at 8:28pm (Last edited: 18 April 2011 8:30pm), Forum Moderator, 1091 Posts

OK, but this is a different issue alltogether...

1. by 'rights' I mean the webserver must have read/write permission in the assets/ directory...

2. I don't know what platform your site is on. (WAMP, LAMP, IIS?) but you might check the .htaccess file in your /assets directory, that denies certain filetypes. There have been issues with that before, though I can't find the post at the moment/nor the solution. Just temporary remove the file and see what gives.

If this works, search the forums, 'cause I know there's a solution hiding here somewhere :-)

btw: don't send tiff images, better to create a jpg/png/gif for it :-)

Avatar
LostBalloon

19 April 2011 at 2:25am Community Member, 16 Posts

Yeah, removing the .htaccess file did the trick

Avatar
LostBalloon

19 April 2011 at 2:26am Community Member, 16 Posts

Any idea how i should fix the file for it to work properly? :S

Avatar
LostBalloon

19 April 2011 at 2:51am Community Member, 16 Posts

Nevermind, thanks, i opened the file and added the unity3d extension to the regular expression of allowed extensions and it works.

:D thanks for all your help!