Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

"Page not found" when trying to access admin


Go to End
Reply

10 Posts   1463 Views

Avatar
ojdavey

11 August 2011 at 9:15pm (Last edited: 11 August 2011 9:15pm), Community Member, 6 Posts

Hi,

After moving a site from the development environment to a live SSL encrypted production environment the admin is suddenly not working and I'm getting a "Page not found" error.

Anyone have any ideas?

Thanks!

Owen

Avatar
martimiz

12 August 2011 at 1:50am Forum Moderator, 1091 Posts

Do you have mod-rewrite enabled on your production environment? Did you maybe copy the silverstripe-cache directory as well - in which case you might want to do a /dev/build/?flush=1 on your new install?

Avatar
ojdavey

12 August 2011 at 11:17pm Community Member, 6 Posts

Thanks for the reply. Yes, mod-rewrite is enabled on the production server. I've also done a /dev/build/?flush=1 and it made no difference. So frustrating because the client can't edit their site! Any other ideas would be most welcome :)

Avatar
martimiz

13 August 2011 at 3:12am Forum Moderator, 1091 Posts

Are you able to login when using yourdomain/Security/login instead of yourdomain/admin?

Also: maybe this thread could help you some, where it was something like a rights issue on the cache directory: http://www.silverstripe.org/general-questions/show/9928

Avatar
ojdavey

15 August 2011 at 9:22pm Community Member, 6 Posts

Thanks again. Yes I can login with Security/login but then it still has the same 404 error when I go to /admin. Thanks for the link, this rights issue could definitely be the problem. I'm going to contact the server host and see what the permissions are set at. I'll post the outcome on here so to maybe help others.

Avatar
ojdavey

15 August 2011 at 11:40pm Community Member, 6 Posts

Arghh, got the permissions changed and STILL not working. Think I'm going to break something :-p

Avatar
martimiz

16 August 2011 at 1:19am Forum Moderator, 1091 Posts

Don't... :-)

I overlooked the fact that you're using SSL... This is new to me so I can't be of much help. You'll find some links googling 'silverstripe ssl admin' that might point you somewhere.

It could have something to do with the setting of secure cookies... Unfortunately the old SilverStripe docs on SilverStripe SSL are no longer available...

I did find this about forcing your entire site to run on SSL: Director::forceSSL(); (in config) Maybe the answer lies in that direction? Good luck!

Avatar
ojdavey

18 August 2011 at 9:17pm Community Member, 6 Posts

Thanks again for all your help. Still not working though. I've put in the forceSSL and tried a few other things but still no luck. I even tried to track through the code to try and work out what was going on. Just got myself more confused :(

Go to Top