Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

/dev/build stopped working (?)

Go to End

10 Posts   1264 Views


22 August 2011 at 7:51am (Last edited: 22 August 2011 7:54am), Community Member, 38 Posts

Hi All,
I'm having a bit of a problem, and hoping someone can help!
I've uploaded a new module, and changed a setting (as per the tutorial - enabled search), and have tried to run /dev/build/. The problem starts here, as the page always brings back nothing new. There is no green or red text here to say new tables have been created, or any records added, I simply get a black text list as if nothing happened.

Can any one help me with this please?

Thanks in Advance,

[[ Edit Note ]]
I've just tried to install the dashboard module. Although no text has shown, when I now go to 'View Page in: CMS', it takes me to the dash board page rather than the page view. However, I see an error as 'There is an internal server error'.


22 August 2011 at 8:16am Forum Moderator, 1796 Posts

Hi Parker,

"'There is an internal server error'." this mean you need to turn on dev mode. Please read



22 August 2011 at 9:42pm Community Member, 38 Posts

Thanks for your reply. My /mysite/_config.php now consists of this line:


However, I still get the same error at the URL 'admin/dashboard/'

/dev/build still doesn't do anything.

Sorry to be a pain!


22 August 2011 at 9:47pm Forum Moderator, 1796 Posts

right, did you try some other debbugings?

add this to your _config.php

SS_Log::add_writer(new SS_LogFileWriter('sserrors.txt', SS_Log::ERR);

and then check for the file in the sapphire folder


22 August 2011 at 10:57pm Community Member, 38 Posts

Thanks. No file seems to be generated. The only thing I've found is in the web server logs, and is as follows:

[Mon Aug 22 11:56:26 2011] [error] [client xx.xx.xx.xx] PHP Fatal error: Class 'SimplePie' not found in /path-to-files/public_html/dashboard/code/dashboard_plugins/SSNews.php on line 30

Other than that - nothing is generated.


22 August 2011 at 11:02pm Forum Moderator, 1796 Posts

well spotted - is the module you installed the blog module then?


22 August 2011 at 11:09pm Community Member, 38 Posts

It's not. It's the dashboard module (


22 August 2011 at 11:15pm Forum Moderator, 1796 Posts

then something is causing it not to sind the class SimplePie
simple as that - search the code for "simplepie" to find

1) where this module is trying to include it from
2) where the class actually is

then just make sure 1 is hooked up with 2 :)

Go to Top