Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Create a User Defined Form


Go to End
Reply

12 Posts   779 Views

Avatar
Chipie

9 November 2011 at 2:40am Community Member, 16 Posts

Hi, I am brand new to SilverStripe and have just installed it. I am currently working through the help topics that concern the features that I wish to add to my website. I want to add a user defined form but when i click on 'Create' and scroll down for 'user defined form' the option isnt available. All I have are 'page', 'Redirector page', 'Error page' and 'Virtual Page'.
Do I have to install something first or update to receive the other options?

Any help is appreciated

Thanks
Chipie

Avatar
swaiba

9 November 2011 at 3:42am Forum Moderator, 1796 Posts

Hi Chipie,

Welcome to the forums!

You need to install (http://doc.silverstripe.org/sapphire/en/topics/modules#installation) the module...

https://github.com/silverstripe/silverstripe-userforms

Avatar
Chipie

9 November 2011 at 4:34am Community Member, 16 Posts

Thanks for that. If I have this correct then, if i want to add any new feature such as a blog or picture gallery, then i should be installing a module for it first?

Thanks again for help

Chipie

Avatar
swaiba

9 November 2011 at 4:38am Forum Moderator, 1796 Posts

Yes that if you want to extend the system with modules, you need to install them.
Or you can code them - this is why people choose silverstripe not for it's module to theme library - but it's ability to be customised thorught coding.

Avatar
Chipie

9 November 2011 at 4:59am Community Member, 16 Posts

Hi installed the module I want but read something about dev/build/ could you explain what I have to do exactly.
I am running the website on a local webserver.

Thanks

Chipie

Avatar
swaiba

9 November 2011 at 5:05am Forum Moderator, 1796 Posts

how about watching the "screen blast" on the home page?
http://www.silverstripe.org/

Avatar
Chipie

9 November 2011 at 8:42am Community Member, 16 Posts

That video is brilliant solved a lot of problems for me.
I have been trying to rebuild the database but keep getting an error, page not found.
I have installed silverstripe files into a folder called caseproject.
http://localhost/caseproject/dev/build?flush=1

Any ideas?

Chipie

Avatar
swaiba

9 November 2011 at 8:53am Forum Moderator, 1796 Posts

could be because you don't have mod_rewrite turned on...

try turing it on (wamp -> apache -> apache modules -> scroll and tick rewrite_module)
or try using the index.php to fake it... http://localhost/caseproject/index.php?/dev/build?flush=1

Go to Top