Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page-type reverts to Error-page


Reply

3 Posts   363 Views

Avatar
Ernie

9 December 2011 at 5:00pm Community Member, 3 Posts

Hi, I have created a new page type but cannot apply it. After applying PT "X" to web page "abc" it reverts to PT "Error Page" after saving.

It was working and then something [?] happened that I cannot find.

Any ideas?

Thanks Ernie

Avatar
Devlin

9 December 2011 at 10:54pm (Last edited: 9 December 2011 10:57pm), Community Member, 215 Posts

Check the page record in the SiteTree table (in phpMyAdmin) and manually apply the new page class to the record. Go back to the cms and publish the page. This usually happens if you delete or rename a page class.

Avatar
prawnstar

10 December 2011 at 4:57am Community Member, 116 Posts

There's another post about this somewhere...can't seem to find it at the moment, but like Devlin said, this usually occurs after you delete or rename a page controller after you have already created pages.

Look at the SiteTree and SiteTree_Live tables in your db and look at the 'ClassName' column. The page you're having issues with will be the ones where the class name is blank. Just manually edit these rows.

At one time there was a bug report filed for this.

Chris.b