Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

defining Homepage URL Segment


Reply

3 Posts   810 Views

Avatar
Silverfish

17 January 2012 at 3:00am (Last edited: 17 January 2012 3:01am), Community Member, 59 Posts

Hi All,

when requesting a page domain root (i.e. http://example.com/) silverstripes searches and displays a page with url segment 'home'.
I am trying to run a homepage with another url segment (i.e. testing) so that if you request http://example.com, you will get redirected to http://example.com/testing and get this page displayed. I already achieved this, by entering the url segment, deleting the default 'home' age and setting "is homepage for" on the new homepage (with testing as url segment). This did work, until i ran the next /dev/build, there the systems creates a new default homepage.

My current workaround is to create a redirector page to testing, that has 'home' as url segment. But I don't like this too much since this Redirector page may confuse the customer.

Any Ideas anone?

Thanks a lot

Regards
S.F.

Avatar
benshu

28 February 2012 at 2:03am Community Member, 4 Posts

Hi Silverfish,

in your _config.php file, try using:

Director::addRules(100, array(
'' => '->testing',
));

I just discovered this while searching on something similar:
http://www.silverstripe.org/archive/show/52

Avatar
socks

1 May 2013 at 3:19am (Last edited: 1 May 2013 3:19am), Community Member, 190 Posts

Looks like adding to _config is deprecated in SS3. http://doc.silverstripe.org/framework/en/reference/director

I'm trying to add to routes.yml, but it still makes a Home page with the URL of /home. The redirect seems to work, just don't want Home when I dev/build.

mysite/_config/routes.yml

---
Name: customroutes
After: '#coreroutes'
---
Director:
rules:
'': '->my-custom-homepage-url'

Any suggestions?

Thanks