Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Fatal Error


Reply


4 Posts   780 Views

Avatar
extasey

Community Member, 14 Posts

26 January 2012 at 1:14pm

I am receiving this error when trying to load the main page of the website:

Fatal error: Class 'Debug' not found in /home/lovecak2/public_html/sapphire/core/Core.php on line 252

Commenting out the line makes the website attempt to point you at /install.php which was deleted after the initial setup.

This is the section where its throwing the error:

///////////////////////////////////////////////////////////////////////////////
// POST-MANIFEST COMMANDS

/**
* Load error handlers
*/
Debug::loadErrorHandlers();

///////////////////////////////////////////////////////////////////////////////

Any help extremely appreciate... I don't know if the client has done anything unusual to cause this.

Avatar
swaiba

Forum Moderator, 1808 Posts

27 January 2012 at 2:50am

whenever I get the site redirecting to install.php it is becasue there is something seriously wrong with the _config.php in mysite...

*not there at all
*db crendetials invalid

other things that cause this sort of error (i think) are not havign the right cache built so dev/build?flush=1 and ensure that the cache is wiped - make a silverstripe-cache in teh webroot (or if you have one empty it)

Avatar
extasey

Community Member, 14 Posts

28 January 2012 at 3:03pm

This is all that is contained in my _config.php file (in the root of the tree)

<?php

Director::addRules(10, array(
   'metaweblog' => 'MetaWeblogController'
));

?>

After doing a flush, this code is dumped to the top of the website: (?flush=1)

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/FileUploadField.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/FileUploadField.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/ImageUploadField.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/ImageUploadField.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/MultipleFileUploadField.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/MultipleFileUploadField.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/MultipleImageUploadField.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/MultipleImageUploadField.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/UploadifyField.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/UploadifyField.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/s3/S3.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/s3/S3.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/s3/S3.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/s3/S3.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/s3/S3File.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/s3/S3File.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/s3/S3MultipleUploadField.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/s3/S3MultipleUploadField.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Warning: There are two files both containing the same class: '/home/lovecak2/public_html/uploadify/code/s3/S3UploadField.php' and '/home/lovecak2/public_html/uploadify/trunk/uploadify/code/s3/S3UploadField.php'. This might mean that the wrong code is being used. in/home/lovecak2/public_html/sapphire/core/ManifestBuilder.php on line 487

Avatar
extasey

Community Member, 14 Posts

28 January 2012 at 3:05pm

The flush fixed my problem though, the website is now up and running. Thanks for your help!