Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

EN GB Spell-checker option?


Reply


2 Posts   672 Views

Avatar
Spaghetti

Community Member, 32 Posts

9 February 2012 at 6:03am

Hello,

I'm trying out SilverStripe CMS and I'm struggling with one issue. When I installed SS on WAMP, I selected English (United Kingdom), so I was surprised to see that the spell checker defaulted to US English. I was even more surprised to see that it was the only option of the drop down list in the page editor.

Having searched google and this forum, I found a hack to edit the config file so that UK English is the option in the drop down but this is all accademic anyway as the spell-checker seems to crash when I click on the link in both Chrome and Firefox.

I notice that this forums edit box has a decent spell-checker and that it's even UK English (if you register as EN UK). So why can't Silver-stripe spell-checker work as well as the Silver Stripe forum edit box?

This is a major bummer for me because being able to spell check your work is half of the benefit of using a CMS, IMHO. Hey ho.

Any thoughts or suggestions on how to fix this? Welcome....

Avatar
dio5

Community Member, 501 Posts

20 June 2012 at 9:16pm

For what it's worth now that SS3.0 is coming out...

The issue is in CMSMain.php. around line 97:

$langName = i18n::get_locale_name($this->Locale);
HtmlEditorConfig::get('cms')->setOption('spellchecker_languages', "+{$langName}={$this->Locale}");

You need to change it into:

$langName = i18n::get_locale_name($this->Locale);
$langCode = i18n::get_lang_from_locale($this->Locale);
HtmlEditorConfig::get('cms')->setOption('spellchecker_languages', "+{$langName}={$langCode}");

   

The google spellchecker won't work if it sends the lang as nl_NL or en_GB... it does when it's nl or en....