Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Why does the link from poweredsites.org cause an SS site to behave so strangely?


Reply


2 Posts   488 Views

Avatar
vwd

Community Member, 160 Posts

19 May 2012 at 1:51am

Edited: 19/05/2012 1:52am

Hi,

Just wondering why a link from [url=http://sites.poweredsites.org/markwaltersmediation-com-au]poweredsite.org[/url] (click on the Mark Walters Mediation Victoria link) is causing an SS site to not render properly. It is as if a 404 page is being rendered with just the default data from a clean SS installation (only the default pages - home, about us & contact us - but no content whatsoever). Weird! Simply refreshing the same 404 error page URL loads the page normally.

There seems to be nothing wrong with the link href. In any case, even if an incorrect URL is requested, it should display the normal 404 page / site, with the full set of pages in the menu and the standard content of the template.

Any ideas?

Thank you.
VWD.

Avatar
vwd

Community Member, 160 Posts

25 July 2012 at 2:06pm

This is still a problem and is super strange.

Is this exposing an underlying SilverStripe problem? Only SilverStripe sites listed on [url=http://poweredsites.org/user/vitessewd]poweredsites.org[/url] exhibit this behaviour - except for Vitesse's own SS site.

I thought I'd provide a shortened URL via TinyUrl and goo.gl as a workaround but still the same.

Below is the GET header summary:

Request URL:http://www.markwaltersmediation.com.au/
Request Method:GET
Status Code:404 Not Found

Request Headers
Accept:text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Encoding:gzip, deflate
Accept-Language:en-us
Cache-Control:max-age=0
Referer:http://sites.poweredsites.org/markwaltersmediation-com-au
User-Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2

Response Headers
Accept-Ranges:bytes
Cache-Control:public
Connection:close
Content-Encoding:gzip
Content-Length:4334
Content-Type:text/html; charset=utf-8
Date:Wed, 25 Jul 2012 01:56:26 GMT
Etag:"35ef-4fb1f559-0"
Last-Modified:Tue, 15 May 2012 06:19:05 GMT
Server:LiteSpeed
Vary:Accept-Encoding, User-Agent, User-Agent
X-UA-Compatible:IE=Edge,chrome=1

And below is the normal GET header summary:

Request URL:http://www.markwaltersmediation.com.au/
Request Method:GET
Status Code:200 OK

Request Headers
Accept:text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
User-Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2

Response Headers
Cache-Control:no-cache, max-age=0, must-revalidate, public
Connection:close
Content-Encoding:gzip
Content-Type:text/html; charset="utf-8"
Date:Wed, 25 Jul 2012 01:59:50 GMT
Expires:Thu, 19 Nov 1981 08:52:00 GMT
Pragma:no-cache
Server:LiteSpeed
Set-Cookie:bypassStaticCache=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; path=/; httponly, bypassStaticCache=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; path=/; httponly
Transfer-Encoding:Identity
Vary:Accept-Encoding, User-Agent, User-Agent
X-Powered-By:PHP/5.3.10
X-UA-Compatible:IE=Edge,chrome=1