Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba


Go to End

2 Posts   557 Views


Community Member, 1 Post

9 June 2012 at 12:55am

Dear Silverstripe Users,

Since a couple of weeks our website has been used by a spambot to post comments.
I found some examples of how to disable this feature yet none of them work in version 2.4

Which way would be best to disable this feature as we don't use this in the website at all.

Any help would be greatly appreciated,

best regards,



Forum Moderator, 5521 Posts

9 June 2012 at 10:37pm

You can turn off comments on a page by page basis by unticking the 'Allow Comments' checkbox in the CMS under the pages 'Behaviour' tab. Or you can remove the $PageComments variable from themes/yourtheme/templates/layout/ as then nothing can be rendered into the page.