Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SS3 multilingual


Go to End
Reply

11 Posts   1400 Views

Avatar
spierala

28 June 2012 at 1:21am (Last edited: 25 July 2012 1:56am), Community Member, 80 Posts

Hello all,
I wonder if ss3 would be recommended for a multilingual site.

so far i can´t find much documentation about it.
any advice would be highly appreciated.

I think this is very important. Why there is not a little tutorial on that topic? I thought SS3 will really show off now with managing multilingual sites...

thx and kind regards,
Florian

Avatar
spierala

25 July 2012 at 2:02am Community Member, 80 Posts

ahhh I´ll try to become lucky here:
https://github.com/silverstripe/silverstripe-translatable

Avatar
dc6jgk

25 July 2012 at 2:43am Community Member, 3 Posts

If you manage to get that to work properly, please let me now.
I have played with that for almost a day now without getting it to produce a properly rendered translated page. Translated pages are accessible but the CMS never seems to apply the theme correctly, independent of which theme is selected.

(see http://www.silverstripe.org/all-other-modules/show/20463 )

Avatar
spierala

16 August 2012 at 1:17am Community Member, 80 Posts

I just installed this:
http://www.silverstripe.org/translatable-module/

which is supposed to be a 1.0.0,
but it does not work at all (with SS 3.0.1)

If I select in the Pagetree a new Language and Press the Button "GO" then I get a white page with the text "The action 'LangForm' does not exist in class CMSPagesController".

In Edit Page View when I select the Tab Translations and select a language and press "CREATE" nothing happens...

Kind regards,
Florian

Avatar
danzzz

28 August 2012 at 5:53am Community Member, 175 Posts

have the same issue ... I thougt this is a stable version 1.0.0, the download link promisse that
http://www.silverstripe.org/assets/modules/stable/silverstripe-translatable-1.0.0.tar.gz

or do we anything wrong??

Avatar
spierala

28 August 2012 at 6:01am Community Member, 80 Posts

hey danzzz,
The problems seem to be fixed in the latest commits of cms and translatable on git:
https://github.com/silverstripe/

worked fine for me.
Regards,
Florian

Avatar
danzzz

28 August 2012 at 7:42am Community Member, 175 Posts

thx spierala,

that dont worked for me ... I downloaded the latest "silverstripe-cms" files and the latest "silverstripe-translateable" ...
you thougt that, right?

Avatar
spierala

28 August 2012 at 7:43pm Community Member, 80 Posts

hey danzzz,
what exactly does not work?
so did you get the latest files?
https://github.com/silverstripe/silverstripe-cms
https://github.com/silverstripe/silverstripe-translatable
just download the zips there.
greetz,
florian

Go to Top