Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Password all of a sudden not working


Reply

7 Posts   577 Views

Avatar
Briohny

29 July 2012 at 6:55pm Community Member, 199 Posts

I've had Silverstripe installed for years. Same password and login details for years too. I log in every morning to update the site. Yesterday morning the login page returned the error 'That doesn't seem to be the right e-mail address or password. Please try again.'

NO files have been changed. Nothing has been changed. No reason for this message. Tried from a few different computers. No luck.

I then used the 'forgotten my password reset link' which worked. I saved a new password. Logged into the CMS and all OK.

Then again this morning... same error 'That doesn't seem to be the right e-mail address or password. Please try again.' New password not working after yesterday's reset.

I can't figure out what is going on. Have I been hacked? Went into file history and couldn't see any modifications.

Please help.

Avatar
Briohny

30 July 2012 at 3:07am Community Member, 199 Posts

It seems that the password is only lasting for about 2 hours. i.e. I can log in again and again but after around 2 hours of non-usage, I can't log back in. Above error re-occurring. Any ideas????

Avatar
Hattori

30 July 2012 at 4:57am (Last edited: 30 July 2012 4:57am), Community Member, 20 Posts

It mean password has been changed, you should dump MemberPassword table beetween two hours to see if have any change.

Or, change password, download ur site then run it on ur computer, then increase 3 hours for ur computer time, then login again. If you can still login, it mean ur site got hacked, else check the site code to see if has a password expiration feature.

Avatar
HumanFly

31 July 2012 at 5:56pm Community Member, 2 Posts

I've got the same problem. I'm not really a SS user (just helping out someone else), so not really sure where to start with this?

Avatar
Briohny

31 July 2012 at 6:55pm Community Member, 199 Posts

Still don't know why this is happening. I've had to hardcode the password into the mysite/_config.php file with Security::setDefaultAdmin('admin', 'password');

It's fixed it but not the best resolution.

Avatar
HumanFly

31 July 2012 at 7:11pm Community Member, 2 Posts

Cheers for the tip! It "fixes" the problem for the admin account but all the users in the system still have the same issue. Painful stuff!

Ps. Are you in Australia or working late somewhere else in the world?

Avatar
Briohny

1 August 2012 at 1:57am Community Member, 199 Posts

Haha - na I'm living in Ireland at the moment!